ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Airheads (http://www.advrider.com/forums/forumdisplay.php?f=85)
-   -   Fix for Acerbis (OMG) petcock, left and right ones now point the right way!! (http://www.advrider.com/forums/showthread.php?t=554615)

One Less Harley 02-27-2010 05:26 PM

Fix for Acerbis (OMG) petcock, left and right ones now point the right way!!
 
Some of you might recall my issues with the left and right acerbis petcock levers pointing the opposite way when off or reserve.

http://www.advrider.com/forums/showthread.php?t=550703

http://i151.photobucket.com/albums/s...ispetcocks.jpg


Well I decided that the problem could be fixed.

1st unthread the plastic strainer from the left valve body, grasp it with your fingers next to the body.

http://i151.photobucket.com/albums/s...s/IMG_0475.jpg


Then pull the long tube out of the body and insert it to the other hole. The front opposite of the barbed fitting.

http://i151.photobucket.com/albums/s...s/IMG_0474.jpg

Ok now the easy part is done.

Now remove the two screws which hold the lever retaining ring. Pull out the guts.

Sorry for the lack of pictures next, but take the valve guts and use a dremel tool to cut a grove in the body this new grove will allow you relocate the lever 180 degrees. You can see where the old grove was. It's the area with the filled in epoxy. I cut the new grove first, also roughen the original grove to give the epoxy something the bite to. Once filled in and allowed to harden overnite the valve was sanded with 220 dry sandpaper and worked down to 600 grit. Place paper on a flat surface and sand the back side of the body. Make sure surface is free of any voids or scratches.


http://i151.photobucket.com/albums/s...s/IMG_0472.jpg http://i151.photobucket.com/albums/s...IMG_0473-1.jpg


Before putting petcock back together sand off the "OFF" and "RES" letters from lever retaining ring. Then w/ a dremel engrave "OFF" and "RES" in the new locations.

Put valve in body, then spring, and place lever on valve 180 degrees out, place a little blue loctight on the two screws for the lever retaining ring. Then tighten up the lever retaning ring.

http://i151.photobucket.com/albums/s...s/IMG_0479.jpg

http://i151.photobucket.com/albums/s...s/IMG_0478.jpg

bgoodsoil 02-27-2010 07:04 PM

well thank you very much :ddog now I have another thing to put on my bike's "to do" list.

One Less Harley 02-27-2010 08:10 PM

Hey at least your ridding yours!!!! I did get the G/S out last Sunday for some gravel riding at Mammoth Cave, it's dirty once again! Only four gravel roads to ride there, got a sore throat from the cool air, had that all week. Hopefully ride tomorrow cause I don't want my sore throat to go away!!

The HPN tank doesn't feel as heavy as I thought, IT'S GREAT TO HAVE 250 MILES ON IT AND HAVE ABOUT 150 LEFT!!! Keeps some cold air off the legs too. Love that big ugly thing!!


Be very careful cutting the grove as if the cutting bit slips.........you'll bugger up the flat surface of the valve body. I wasted three dremel bits on the soft pot metal (maybe aluminum). I hope the epoxy doesn't let loose..

WTF- didn't the manuf just make two other parts to make the valve RIGHT!!!! It's only one stamped piece of steel with letters on it and another valve body cam thingy. I don't get it.

BTW-how's that trany holding up?

bgoodsoil 02-27-2010 09:20 PM

the gearbox is doing good! Man, having a first gear is really nice. I can pull away from stop lights and everything. I guess it's like any other luxury item--now that I've got one, I don't know how I lived without it for so long. :D

One Less Harley 07-06-2010 07:58 PM

My fix with the epoxy was temporary. Should have known better than use epoxy. The epoxy should have held up to gasoline, but didn't. I noticed the left petcock was leaking.

So I removed the "valve" and took it to a machinist so he could make two of them. The old altered one is on the right, see the black epoxy. New one on the left has centering scribe marks which were sanded down flat w/ 220 then 500 grit. The original is a cast part the new is machined billet AL.


Rucksta 07-07-2010 04:43 PM

Thanks for the heads up on the expoxy.
I've been holding off doing this and now know how to proceed.

Great idea. I use reserve on the Acerbis tank so infrequently I'm still unfamilliar with it.
When I need it I'm usually fatigued and prone to making errors esp with confusing one way or the other valves..

walkbar 02-24-2014 02:19 PM

I think I'll just clean the plate and put a red blob of paint on the OFF and green on the ON.
Unpainted is RES. Then lacquer?
I'm a lazy fella though... :)

Twotaildog 02-25-2014 08:12 AM

Good idea. Being a lazy fellow also, I probably would have just taken a big magic marker and written 'ON ------- OFF' on the right side of the tank and 'OFF ------- ON' on the left side of the tank in about 2" letters. Your solution is much more elegant.


.

One Less Harley 02-25-2014 09:04 AM

no need to mark the petcocks if not changing the orientation of the valves.

It's just attention to detail, very disappointing that whoever designed the parts didn't have the metal capacity to realized the left and right petcocks using the same internals would point in opposite directions when off or on. What's wrong with doing things right.

That would be manufacturing two more parts, the internal valve and lever retention plate.

dm635 02-25-2014 01:14 PM

I had a different problem with my reserve. Both do however point to the top. I found out in just a couple days that my reserve did not function. Coasted to the side of the road after my new baby ran out of fuel. Switching to reserve did nothing. Found out soon that the reserve tubes were plugged solid allowing no flow. I disassembled the petcocks cleaning all the passages only to discover the seals had lasted past their prime once back together creating couple nice little leaks. New seals and another rebuild I was back in business. Apparently the PO never switched to reserve and fueled up before it ran low. And all those years he owned it caused the reserve tubes to solidify with hard chunky fuel deposits. I now run the reserve time to time keeping the fuel flowing and prevent clogging.

globalt38 02-25-2014 02:13 PM

Quote:

Originally Posted by dm635 (Post 23554002)
Apparently the PO never switched to reserve and fueled up before it ran low. And all those years he owned it caused the reserve tubes to solidify with hard chunky fuel deposits. I now run the reserve time to time keeping the fuel flowing and prevent clogging.

Never even thought of that - I do run reserve occasionally but very infrequently as I usually pay attention to my odometer and fill up prior to entering reserve zone. I'll make a point to run the reserve on purpose on occasion to keep that from happening. :beer

dm635 02-26-2014 10:56 AM

Cool, I hope it helps. I had to use a drill bit to clear the tubes. Both were totally sealed with no flow. I was rescued by the PO's wife. Called his phone since he was the closest to where I became stranded. I spent more time troubleshooting than it took her to bring me fuel.


Times are GMT -7.   It's 01:46 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014