ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Ask Baldy, blame AceRph (http://www.advrider.com/forums/forumdisplay.php?f=8)
-   -   De-clutter ride reports and other threads (Google Chrome extension) (http://www.advrider.com/forums/showthread.php?t=730367)

James Adams 10-02-2011 01:38 PM

De-clutter ride reports and other threads (Google Chrome extension)
 
I had used tbolt's excellent De-crufter for Firefox for quite a while back before I discovered Google Chrome. For those of you who are now using Chrome (like myself), I have an extension with similar functionality.

Like the De-crufter, once you visit the first page of a thread, the OP will be remembered (even if you close the browser and open it again later, if you don't clear your browsing data). Posts that you post to a thread won't be hidden with the clutter if you're logged in. In addition, the clutter show/hide setting is saved on a per-thread basis.

I added an entry in the Thread Tools menu to show/hide clutter as demonstrated below.

https://lh3.googleusercontent.com/-c...8ba1f5e014.jpg
(cRAsH theme shown above, this should work with most of the themes just fine, excluding ADVrider 2.0)

For the interested, the source code is viewable here. Feel free to make your own version if you'd like—with a few tweaks, it should work reasonably well on almost any vBulletin-powered site.

Tweaker 10-10-2011 12:38 PM

Thanks for that. Inane junk responses are the one thing that keeps me out of RR.

Bulleteer 01-03-2012 09:13 PM

Excellent extension, James Adams. It works perfectly.

I really like it that you show the authors of the hidden posts. Easy to pick and choose which replies to read.

:thumb

James Adams 01-04-2012 08:04 AM

Quote:

Originally Posted by Bulleteer (Post 17657034)
Excellent extension, James Adams. It works perfectly.

I really like it that you show the authors of the hidden posts. Easy to pick and choose which replies to read.

:thumb

Thanks! Sometimes you can see that the OP replied to someone's post, but they didn't quote the whole thing. This makes it easy to go back and read that specific post.

PackMule 01-04-2012 06:53 PM

Nice work! :beer

James Adams 01-04-2012 07:17 PM

Quote:

Originally Posted by PackMule (Post 17665439)
Nice work! :beer

Thanks! Any feature requests? On my list (whenever I have some time :evil) is to have it load the whole thread so you don't have to turn pages.

PackMule 01-04-2012 09:10 PM

Quote:

Originally Posted by James Adams (Post 17665658)
Thanks! Any feature requests? On my list (whenever I have some time :evil) is to have it load the whole thread so you don't have to turn pages.

That could be crippling, depending on the thread (thinking of some of the Ride Reports, in particular).

Maybe something that pushed the number of posts loaded out, but didnt' grab the whole thing?

James Adams 01-04-2012 09:13 PM

Quote:

Originally Posted by PackMule (Post 17666709)
That could be crippling, depending on the thread (thinking of some of the Ride Reports, in particular).

Maybe something that pushed the number of posts loaded out, but didnt' grab the whole thing?

It could do it asynchronously in the background (initiated by a button click or something) while you're still working on the first page, adding posts to the end of the page as they're loaded.

At least that's how it works in my head. :lol3

James Adams 01-12-2012 11:18 AM

Quote:

Originally Posted by James Adams (Post 17666727)
It could do it asynchronously in the background (initiated by a button click or something) while you're still working on the first page, adding posts to the end of the page as they're loaded.

At least that's how it works in my head. :lol3

This has been implemented now. The extension will preload (in the background) the next three pages of whatever thread and page you're on.

pckopp 01-19-2012 08:57 AM

Is this extension currently working? I just added it and clicking Hide or Show doesn't do anything. I have Win7_64 and the current Chrome. I closed and reopened Chrome.

I love the idea, just no go at the moment. Or so it appears.

Thanks.

James Adams 01-19-2012 09:01 AM

Quote:

Originally Posted by pckopp (Post 17781363)
Is this extension currently working? I just added it and clicking Hide or Show doesn't do anything. I have Win7_64 and the current Chrome. I closed and reopened Chrome.

I love the idea, just no go at the moment. Or so it appears.

Thanks.

Hi Phil,

Which ADVrider theme are you using? Right now, this doesn't work with the "ADVrider 2.0" theme, even though it still shows the menu option. I use the cRAsH theme but it should work with the others (besides 2.0), too.

I've edited the first post to reflect this.

http://new.tinygrab.com/0e392405f069...74539eac05.png

-JA

pckopp 01-19-2012 09:06 AM

Quote:

Originally Posted by James Adams (Post 17781392)
Hi Phil,

Which ADVrider theme are you using? Right now, this doesn't work with the "ADVrider 2.0" theme, even though it still shows the menu option. I use the cRAsH theme but it should work with the others (besides 2.0), too.

I've edited the first post to reflect this.

Got it. Thanks! :clap

Bulleteer 01-23-2012 04:30 AM

JA, it seems that since you added the preload feature, the "Hide" setting is not working for the whole thread. I can select Hide on the first page, and it works for that page, but not for the following pages unless I select Hide again.

Any ideas? Win XP and cRAsH theme.

Otherwise I like the preload function. Works nicely on photo-heavy threads.

Thanks

James Adams 01-23-2012 07:24 AM

Quote:

Originally Posted by Bulleteer (Post 17811353)
JA, it seems that since you added the preload feature, the "Hide" setting is not working for the whole thread. I can select Hide on the first page, and it works for that page, but not for the following pages unless I select Hide again.

Any ideas? Win XP and cRAsH theme.

Otherwise I like the preload function. Works nicely on photo-heavy threads.

Thanks

It's quite possible that I broke it. :lol3 I'll take a look.

James Adams 01-23-2012 08:58 PM

fixed in 1.16
 
Quote:

Originally Posted by Bulleteer (Post 17811353)
JA, it seems that since you added the preload feature, the "Hide" setting is not working for the whole thread. I can select Hide on the first page, and it works for that page, but not for the following pages unless I select Hide again.

Any ideas? Win XP and cRAsH theme.

Otherwise I like the preload function. Works nicely on photo-heavy threads.

Thanks

It's fixed now, as of version 1.16. :clap

Thanks for the heads-up! :1drink


Times are GMT -7.   It's 10:43 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014