ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Airheads (http://www.advrider.com/forums/forumdisplay.php?f=85)
-   -   R90S ATE caliper rebuild (http://www.advrider.com/forums/showthread.php?t=741179)

craydds 11-12-2011 08:45 AM

R90S ATE caliper rebuild
 
1 Attachment(s)
https://lh4.googleusercontent.com/-t...0/SSCN0147.JPG
Sorry, a bit out of focus.
My '75 R90S was retired to the barn for several years and was sadly neglected. I am resurrecting the machine, so I'll start with the brakes.

craydds 11-12-2011 08:50 AM

1 Attachment(s)
The calipers came apart and all was fairly clean. All parts were cleaned up, but one of the pistons has some rust.

craydds 11-12-2011 08:55 AM

1 Attachment(s)
It seems that the rust is not internal, not inside the caliper bore, but external to the seal. I think the rust was between the seal and the dust cover. The rust destroyed what appears to be a chrome plating.

craydds 11-12-2011 09:04 AM

https://lh3.googleusercontent.com/-2...0/DSCN0135.JPG
Measuring inside the caliper bore, from the the base to the seal is 21 mm. The rust is at 23 mm from the base of the piston, so it seems that would be external to the seal when the piston is extruded under braking pressure.

H96669 11-12-2011 09:29 AM

Big difference if it happened with worn pads, once you put new ones in there "if needed" then the corrosion may get pretty close from the seal.

But I have remounted pistons like that once satisfied the corrosion wouldn't be too close from the seal. Some rust converter, a little brake grease inside the dust cover and keep an eye on it later just in case.

Make sure the plating is not about to come off farther down, hard to see you really have to try scraping it off with a knife or something.

Clean the groove in the cylinder very very well, that is where all them seized calipers problems usually come from.

I went and had a look at how much BMW wants for a caliper.....EeeeeK!:eek1

craydds 11-12-2011 09:53 AM

My sentiments, exactly, on the cost of new pistons... yikes! It's not that I'm trying to get buy as cheaply as possible, I want to do a good job, but are those pistons made of gold? I will get new pads so I think you may be right about the rusted area contacting the seal.

H96669 11-12-2011 10:44 AM

Got Picasa? 2-3 minutes from taking the pic and posting. I think you are going straight from your computer....files too big.

craydds 11-12-2011 02:24 PM

Thanks for the tip. Will need to get my 14 yr. old son to teach me how it works. ha!

craydds 11-13-2011 06:28 AM

I have my pictures on Picasa now.

H96669 11-13-2011 07:30 AM

Don't worry....I ain't the best with them computers myself but, a pic is still worth a thousand words, saves a lot on typing and some of us only work well when we can see. All in the details....for some of us!

Little icon at the top here, square kind of yellowish with a little mountain in it , should say "Insert image" when you put the cursor there. Click on that the box will appear and say "Enter URL of your image". Clisk delete to get rid of the HTTP thing,then paste your "embed image link" from Picasa in there.

Picasa: Once you get your pic in there you have to send it(Upload) online then go to "View Online" , click on Links for that image, then select the size you want and at the bottom check "Image only". Then where it says "Embed image"right click on that then "copy paste" that back into the "Insert image" box on here.

I tried with the "Image link" on Picasa, did not work, had to do the "Select size" and "Image only" thing.

There may be another way with Picasa, but that one is kind of new to me also so I piddled with it last week and it does work. So much faster than Photobucket.

Beats asking the nephew.....I think he is still flying from 2 months in India with his mom.:wink:

We really want to see that bike.....in Old's Cool.:wink:

Ouch....having a hard time editing but "Picasa Online" should look like what I copy pasted down there.

<TABLE style="WIDTH: 100%" id=lhid_tablecontent class=lhcl_contentarea cellSpacing=0 cellPadding=0><TBODY><TR><TD id=lhid_trayhandle class="gphoto-trayhandle gphoto-collapsibletrayhandle"></TD><TD style="VERTICAL-ALIGN: top" id=lhid_tray class=lhcl_tray><TABLE class=lhcl_host><TBODY><TR><TD class=lhcl_column_left></TD><TD class=lhcl_column_right>




</TD></TR></TBODY></TABLE>









https://lh5.googleusercontent.com/s/...ransparent.gifLink to this Photohttps://lh5.googleusercontent.com/s/...ransparent.gif

Link
<INPUT id=lhid_link_inputbox class=gphoto-sidebar-inputbox value=https://picasaweb.google.com/lh/photo/2fDSJH6vHllaLL7JoXmyjToYLt4RxkkDiyqZ35FKkQ8?feat=d irectlink readOnly closure_uid_24m1xq="69"></INPUT>
Embed imagehttps://picasaweb.google.com/s/v/83....ransparent.gif
<INPUT id=lhid_snippet_embed class=gphoto-sidebar-inputbox value='<table style="width:auto;"><tr><td>https://lh3.googleusercontent.com/-r...4/IMG_1466.JPG</td></tr><tr><td style="font-family:arial,sans-serif; font-size:11px; text-align:right">From 2011-10-17-1646-31</td></tr></table>' closure_uid_24m1xq="70">

Select size<SELECT id=lhid_snippet_size closure_uid_24m1xq="71"><OPTION selected value=144>Thumbnail 144px</OPTION><OPTION value=288>Small 288px</OPTION><OPTION value=400>Medium-400 400px</OPTION><OPTION value=640>Medium-640 640px</OPTION><OPTION value=800>Large 800px</OPTION></SELECT>
<INPUT id=lhid_snippet_checkbox type=checkbox closure_uid_24m1xq="72">Hide album link
<INPUT id=lhid_just_image_checkbox type=checkbox closure_uid_24m1xq="73">Image only (no link)






https://lh5.googleusercontent.com/s/...ransparent.gifhttps://lh5.googleusercontent.com/s/...ransparent.gif





</TD></TR></TBODY></TABLE>
<TABLE style="WIDTH: 100%" id=lhid_tablecontent class=lhcl_contentarea cellSpacing=0 cellPadding=0><TBODY><TR><TD id=lhid_trayhandle class="gphoto-trayhandle gphoto-collapsibletrayhandle"></TD><TD style="VERTICAL-ALIGN: top" id=lhid_tray class=lhcl_tray><TABLE class=lhcl_host><TBODY><TR><TD class=lhcl_column_left></TD><TD class=lhcl_column_right>




</TD></TR></TBODY></TABLE>















</INPUT>





</TD></TR></TBODY></TABLE>
<TABLE style="WIDTH: 100%" id=lhid_tablecontent class=lhcl_contentarea cellSpacing=0 cellPadding=0><TBODY><TR><TD id=lhid_trayhandle class="gphoto-trayhandle gphoto-collapsibletrayhandle"></TD><TD style="VERTICAL-ALIGN: top" id=lhid_tray class=lhcl_tray><TABLE class=lhcl_host><TBODY><TR><TD class=lhcl_column_left></TD><TD class=lhcl_column_right>




</TD></TR></TBODY></TABLE>


</TD></TR></TBODY></TABLE>

craydds 11-14-2011 09:00 AM

Got it. It worked. I am not a total Luddite, just don't have 12 hr. per day to spend at the computer. Thanks for your help.

craydds 11-14-2011 09:09 AM

https://lh5.googleusercontent.com/-4...0/SSCN0134.JPG
Caliper in good shape, rust on piston between inner seal and outer dust cover.
https://lh5.googleusercontent.com/-i...0/SSCN0150.JPG

craydds 11-14-2011 09:24 AM

https://lh4.googleusercontent.com/-9...0/DSCN0139.JPG
This is the rusted piston after some sanding. The plating was weakened and sanded off with the rust.
https://lh3.googleusercontent.com/-I...0/DSCN0138.JPG
It looks like the defective area could be under the seal, or just exterior to the seal. I guess I'll have to get new pistons.

Xcuvator 11-14-2011 12:04 PM

The pistons may work for awhile, but will rust again and cause the brakes to not release fully.

craydds 11-14-2011 03:03 PM

Time for new pistons. Will place order tonight.


Times are GMT -7.   It's 05:22 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014