ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   2 smokers (http://www.advrider.com/forums/forumdisplay.php?f=84)
-   -   Aermacchi/HD SS250 Winter rebuild/refresh (http://www.advrider.com/forums/showthread.php?t=758259)

Quickv4 01-22-2012 05:44 AM

Aermacchi/HD SS250 Winter rebuild/refresh
 
After 30 years and 14000 miles, Our HD SS250 needed a good rebuild/ refresh. Earlier this summer I had installed a NOS piston to replace the Cagiva SST250 piston with the obsolete rings. The bike ran great after redoing the top end, had excellent compression. I rode over 500 miles all over the rolling hills of Wisconsin. Mid season we spooned on some brand spankin' new Avon Speedmaster tubetypes to replace the decades old OEM Carisles and it was golden.

late last season...

http://img.photobucket.com/albums/v2...s/STA75822.jpg

<iframe width="560" height="315" src="http://www.youtube.com/embed/_C03WfRU4CI" frameborder="0" allowfullscreen></iframe>


During this season, I was riding back from a vintage base ball game I played at, and as I was rounding a nice sweeper and all of a sudden the exhaust/intake note got REALLY throaty. No good place to stop on this hilly sweeper to check things out, so I rode for about 2 miles until I could could get to a quiet cross road. For a little bit it felt like it was soft seizing. Ahh crap. Pull over and pull out the plug, white as a ghost. Pop off the air box cover and lo and behold, the air filter element had popped out of its frame, causing a lean mixture. I pop it back in and start the bike. Runs just as good as before, no harsh intake noise. But now it had a piston tick. Nothing major, but a good tick.

So after I got the bike back home, I popped the cylinder head off and found this...

<iframe width="560" height="315" src="http://www.youtube.com/embed/MakAR73gcRk" frameborder="0" allowfullscreen></iframe>

Piston is toast... mmmm

We only rode the bike once after this. Didn't want to grenade it. Still ran as good as ever.

So this winter I pulled the cases apart and replaced allthe bad bearings and seals and inspected the transmission, as we had been getting progressively more false neutrals between 2nd and 3rd, and 4the to 5th.

<iframe width="560" height="315" src="http://www.youtube.com/embed/1KvmpGnfa40" frameborder="0" allowfullscreen></iframe>

I just sent the crankshaft to Falicon in Florida to get inspected, trued, and welded.

Quickv4 01-23-2012 04:16 AM

Latest Video Update

<iframe width="560" height="315" src="http://www.youtube.com/embed/6KZ6kCx7jCk" frameborder="0" allowfullscreen></iframe>


Times are GMT -7.   It's 09:29 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014