ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   2 smokers (http://www.advrider.com/forums/forumdisplay.php?f=84)
-   -   1965 YJ2 Low compression (60 cc) (http://www.advrider.com/forums/showthread.php?t=762098)

LotaBikes 02-05-2012 01:07 PM

1965 YJ2 Low compression (60 cc)
 
Hello,
Maybe someone can help with a few questions I have. I have a 1965 YJ2 that I am restoring. Everything is basically done except getting the tank re-chromed. I am having some mechanical issues however.The issue is that the bike will start and idle and will rev with no load in neutral. It has no mid-range or high end power though when I go to ride it. Bogs out and dies. So far I have cleaned the carb (multiple times) and adjusted the floats. I have replaced both crank seals, the head and base gaskets. I have done a leak down test and it lost maybe 1/2 psi over 6 mins. The biggest issue seems to be compression. The compression test shows only 40 psi. I didn't think it would even run with it that low.The bike only has 1100 miles on it. I would'nt think the compression would be so low. Do I have to rebore and go to the next size piston or will new rings do the trick? How do I tell? If I do have to get a new piston and rings, what do I tell the machinist the clearance should be? Or should he already know? Any help would be appreciated.

anonny 02-10-2012 10:06 PM

I'd pull the cylinders and the pistons then remove the rings, after that put the rings in their respective cylinders and push them in square with the pistons and measure the ring end gap for starters.

Plus you will see what shape the piston/ cylinders are in as well as seeing if the rings are stuck in the piston grooves.

LotaBikes 02-12-2012 05:15 PM

Despite the lack of interest in my thread, I did resolve the problem. I did remove the piston and measured my wall clearance at .002. Ordered new standard size rings from ebay, checked end gap which was within spec for both, gave the cylinder a light hone and reassembled. Also adjusted the air screw on carb after 20th cleaning. Bike starts and runs good now.:clap Now that it is going good, I found I have leaking seals on the oil pump that I will need to replace. Fortunately they are still available and cheap.

anonny 02-13-2012 08:19 PM

Good stuff, whats the compression now?


Times are GMT -7.   It's 05:37 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014