ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Parallel Universe (http://www.advrider.com/forums/forumdisplay.php?f=77)
-   -   Fuel pump for 800gs (http://www.advrider.com/forums/showthread.php?t=792465)

hurcomb 05-20-2012 04:43 AM

Fuel pump for 800gs
 
Hi
Does anyone know what fuel pump is in the BMW fuel pump assembly? The whole assembly is big bucks from bmw and i think i can resolve my problem with just the pump itself. I assume I can just switch out this part?

I believe it is a common pump used in many cars.

It is an 2009 btw.

GB 05-20-2012 11:11 AM

Are you sure it's the fuel pump? it's more common to have a fuel pump controller issue, than the fuel pump itself. Someone on ADVrider sells a fuel pump controller bypass cable for emergency use (in the Vendors forum).

JRWooden 05-21-2012 06:54 AM

The pump can be "hot wired" (by-passing the controller) if the controller is really your problem, and like GB said, that's a good thing to try if you have not done so....

A "generic" replacement pump had been the subject of much speculation, but AFAIK no one has posted any P/N of pumps that work & fit. The pump is rated at 3.5 bar with 60 l/hr minimum.

Here is an append from one of our resident experts (Joel Wisman) on the topic:

I had a bosch part# that would drop right in size wise. As to the spec above, that is a minimum pass or fail powered through the controller which is always going to be a volt or more lower then 14.2 where these things are spec'd by bosch. The pump I had the # of was same dimensions, terminal configuration, and outlet diameter but 100 l/h

In any case, the part number was in my then desk which is mine no more.

Any pump that you can some how strap onto the bracket so that it hangs near the bottom of the tank and is in the 80-160 lph range should work just fine.

I sold my F8, but if I still had it and it was out of warranty or going somewhere far from civilization, I'd pick a pump from Denso, or Marelli. Bosch pumps aren't doing well with ethanol in any application I am aware of.


chadams 05-24-2012 06:44 AM

Opel Tigra Vectra B Zafira 99-05 FUEL PUMP OPEL 815037

I think I found it on one of the other forums.....

JRWooden 05-24-2012 07:43 AM

I've never held the OEM unit in my hands, but from pictures I have seen this could be a winner! :clap

I found some detailed drawings here:

http://cnnc.en.alibaba.com/productsh...8_9200109.html

Can anyone confirm?

Olvi 05-25-2012 01:34 PM

Quote:

Originally Posted by JRWooden (Post 18732685)

I am an idiot, I know, but can someone tell me, what is the brand of this?

GB 05-25-2012 04:05 PM

The brand is OPEL.

JRWooden 05-25-2012 07:32 PM

Quote:

Originally Posted by Olvi (Post 18766737)
I am an idiot, I know, but can someone tell me, what is the brand of this?

I believe the brand of that particular unit is "Chinese-generic" :lol3
I linked to it because it had the best pictures of what the unit looked like.........
There are several sellers on ebay selling a "compatible unit" .... some as cheap as $30 ....
if it is "plug compatible" we can try to find a "reputable" source ....

chadams 06-30-2012 02:34 AM

So I tried one of the cheap eBay ones... It fitted fine, but at the same time I replace my external fuel filter, air filter, spark plugs, clean the ica, cleaned the air box and all connected sensors, replace all fuel hoses, broke the nipple off the fuel rail and cleaned the fuel pressure sensor...
So I tapped a new nipple into the end of the fuel rail, added so two part epoxy and waited 24 hrs for it to dry. This was two weeks ago and since re-assembling it all the bike ran awesome when cold but once warm had a rough idle. I thought ica so I took it out removed the plunger and lube it, did the tps reset and than tried again.. Still crappy idle..
So after putting up with it for two weeks I fitted the stock fuel pump today and too my surprise my warm idle is now perfect the bike no longer stalls after blipping the throttle..

So from this learning I think I'll be buying a decent brand pump next and I'll try it all over again. :-)

JRWooden 06-30-2012 10:02 AM

I am delighted to learn that the pump is at least dimensionally the same! :clap

So ... if we can find a quality mfg. maybe we'll be in business :wink:

chadams 06-30-2012 09:44 PM

Quote:

Originally Posted by JRWooden (Post 19026967)
I am delighted to learn that the pump is at least dimensionally the same! :clap

So ... if we can find a quality mfg. maybe we'll be in business :wink:

Yes, housing and electrical plug are a match. Problem is either flow rate or spin up time

I will try another brand next now the rest of the bike is running fine and will post my results

JRWooden 07-01-2012 08:11 AM

Quote:

Originally Posted by chadams (Post 19030440)
Yes, housing and electrical plug are a match. Problem is either flow rate or spin up time

I will try another brand next now the rest of the bike is running fine and will post my results

I wonder if ... given enough time ... the bike would "learn to love" a pump with different characteristics....
i.e. if the on-board computer has a set of adaptation values that it uses for the fuel pump controller circuit
(how hard to hit the pump with power ..... )

but that is great news.... even at worst, for $30 it's a nice spare....
I'll take a crappy idle to a dead bike any day!
Thanks for testing this..........

chadams 07-03-2012 06:53 AM

Quote:

Originally Posted by JRWooden (Post 19032067)
I wonder if ... given enough time ... the bike would "learn to love" a pump with different characteristics....
i.e. if the on-board computer has a set of adaptation values that it uses for the fuel pump controller circuit
(how hard to hit the pump with power ..... )

but that is great news.... even at worst, for $30 it's a nice spare....
I'll take a crappy idle to a dead bike any day!
Thanks for testing this..........

That's what I thought, but after 700km it still would cut out at idle :D

JRWooden 07-03-2012 08:07 AM

Quote:

Originally Posted by chadams (Post 19046128)
That's what I thought, but after 700km it still would cut out at idle :D

I wonder what would happen if you just bypassed the pump controller and ran the pump on full system voltage all the time? :evil

IIRC - Joel commented (in another thread) that it wasn't significantly harmful to do that ... the only downside would be that the life of the $30 pump would be shorter..............

chadams 07-03-2012 08:28 AM

Quote:

Originally Posted by JRWooden (Post 19046556)
I wonder what would happen if you just bypassed the pump controller and ran the pump on full system voltage all the time? :evil

IIRC - Joel commented (in another thread) that it wasn't significantly harmful to do that ... the only downside would be that the life of the $30 pump would be shorter..............

I haven't run a controller for the last 70,000km... it was cutting out on me around 30,000k, so it got the chop


Times are GMT -7.   It's 06:06 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014