ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Orange Crush (http://www.advrider.com/forums/forumdisplay.php?f=34)
-   -   Idle issue and terrible gas mileage (http://www.advrider.com/forums/showthread.php?t=842517)

hennessyktm 11-19-2012 06:39 PM

Idle issue and terrible gas mileage
 
Just got back from a trip on my new-to-me 04 950 ADV and got terrible gas mileage..also noticed the idle hung out at 2000 rpms before dropping back down to 1400 rpms. Sometimes it would need to help it get back down by slowing way down while still in gear to bring the rpms down. Also, I get a strong exhaust/rich smell from the bike.

On each tank, I got to around 130 miles before the fuel light would go on...terrible

Its got a 2 to 1 mod, now stainless remus revolution w/ spark arrestor in palce (yeah, I'm the guy who just posted about the smoked carbon remus a few days ago), ContiTrail Attack on RR, Scorpion up front. I was running with the Gobis on and we averaged 80 mph.

Did initial research on the site/google and saw guys mention to check for vaccuum leaks and ensure the carbs were seated properly, etc. I'm gonna tackle that first thing tomorrow morning.

Question, does a vaccuum leak or poorly seated carb lead to poor gas mileage or do I have something else going on?

Thanks in advance for your replies.

MookieBlaylock 11-20-2012 05:35 AM

when you pull the top of airbox and filter take a look straight down through the carbs to the top of the valves. If the float is stuck on one of the carbs fuel will pool ontop of the valves and get horrible mpg. I fixed this issue by spraying lubricant on the float and jiggling it for a while. And obviously while you are in there spray out the jets with carb cleaner. Another possible issue are the rubber diaphragms that just go bad over time, 80 bucks a pop but if the ones in place are 8 years old. Carb cleaner kills these so clean before install

dogsslober 11-20-2012 05:57 AM

Check your coke cable for proper adjustment,if its not releasing all the way it will F up your mileage

hennessyktm 11-20-2012 09:37 PM

Thanks for the tips guys.

So I pulled the bike apart today and found some tell tale signs of what my research has told me is a failed balance shaft seal. The front carb intake had a good bit of oil on it with some pooling beneath the carb. So, I made a two hour drive to the closest KTM dealership, picked up the new seal, and installed it tonight.

I capped the crankcase breather hose fitting on top of the air box and placed a seperate filter on the hose itself in order to prevent any further oil intrusion into the airbox.

Additionally, the BMC air filter looked pretty dirty so I cleaned it (currently drying).

I also noticed the PO put a filter on the carb breather hose (the bike has 1 x capped tube on each carb, with the remaining 2 x tubes joining to a T-fitting. From the T-fitting it goes to a small filter). Anyways, that filter was insanely dirty, smashed up, and straight nasty so I replaced that.

Hopefully, once the filter dries and I get the bike back together, these changes will fix the problems.

MookieBlaylock 11-21-2012 04:28 AM

Quote:

Originally Posted by hennessyktm (Post 20088886)

I also noticed the PO put a filter on the carb breather hose (the bike has 1 x capped tube on each carb, with the remaining 2 x tubes joining to a T-fitting. From the T-fitting it goes to a small filter). Anyways, that filter was insanely dirty, smashed up, and straight nasty so I replaced that..

i bet that's part of the problem. I recently switched from 2 into 1 w/ a filter to just one 7 or 8 inch hose per carb Totally fixed the sketchy throttle at cruise and now runs like a champ with crosswinds

kanur 11-21-2012 08:34 AM

Here ya go............the hanging idle is a rich condition.
http://advrider.com/forums/showthread.php?t=805360
I had the same issues with my 04 when I picked it up last spring. Runs like a champ now and gets 36 to 40 mpg :clap

hennessyktm 11-26-2012 07:34 AM

Appreciate all the feedback. Pretty sure it's fixed, here is what I did:
-Removed the crank case breather hose from the airbox, capped the connection on the air box, and put a breather filter on the hose....no more oil to dumping into the front carb
-thoroughly cleaned the BMC air filter, housing, etc
-removed the 2 to 1 carb vent lines from the bike (which went to a T-connector, then to a small breather filter). Low and behold the filter was really dirty. Individually vented the carbs wih the 10" and 11" lines(as per several other threads)
-checked all caps/seals on the carbs for leaks

At first I did all of the above except individually vent the carbs. Instead I put a new, clean filter on the end of the 2 to 1line. First time out it had made serious improvements down low (could now easily wheelie in 1st and 2nd), but severely bogged at higher speeds and over 4500 rpms. I went back to the house and individually vented the carbs. Took the bike back out and WOW! Now it runs like everyone else describes. The idle issue is much better too, I think the dirty air filter and carb vent filters were to blame.

Gonna put a tank of fuel through it and see what type of mpg I've got.

Johnf3 11-26-2012 09:24 AM

Quote:

Originally Posted by kanur (Post 20091121)
Here ya go............the hanging idle is a rich condition.
http://advrider.com/forums/showthread.php?t=805360
I had the same issues with my 04 when I picked it up last spring. Runs like a champ now and gets 36 to 40 mpg :clap

A hanging idle is usually indicative of a lean condition. A rich idle condition will have the engine idle low and then gradually gaining speed until normal.


Times are GMT -7.   It's 08:21 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014