ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Crazy-Awesome almost Dakar racers (950/990cc) (http://www.advrider.com/forums/forumdisplay.php?f=34)
-   -   Gaskets O rings for carbs (http://www.advrider.com/forums/showthread.php?t=843052)

rossguzzi 11-22-2012 04:48 AM

Gaskets O rings for carbs
 
Do I need to buy any just to alter the needle ?
Cheers

DSM8 11-22-2012 06:13 AM

Depends on age and condition of carbs sudco can provide you with most individul parts google them.

cjracer 11-22-2012 06:40 AM

Quote:

Originally Posted by rossguzzi (Post 20096932)
Do I need to buy any just to alter the needle ?
Cheers

No, the small o-rings that cause gas leakage are on the gas inlet barbs.

You won't be near those when you adjust needles.

Inspect the diaphram and make sure its seated properly when reinstalling the black plastic cap. These can rip with age.

We have all these items in stock if you need them.

geometrician 11-22-2012 08:14 AM

Quote:

Originally Posted by cjracer (Post 20097335)
No, the small o-rings that cause gas leakage are on the gas inlet barbs

I've found the only time the four o-rings on the brass 90-degree elbows leak is when the carbs have been off for a length of time. Upon turning the engine stop switch to "run" & the fuel pump running, they leak.

However waiting several hours (overnight usually) when you try again the o-rings don't leak. Seems the gasoline causes them to swell & they fix themselves... DAMHIK

CJ, good to know you've got the o-rings in stock, they're tricky to find!!!

take your time & all should go well; make sure you use a quality screwdriver so you don't damage the Phillips scews.

rossguzzi 11-22-2012 08:33 AM

Thanks for the info, one more thing......

Should I try to get the 2 carb vent hoses into a more 'still air' place than just under the air box? I have read doing a 2 into 1 with a small filter can cause probs. I was thinking of doing this and tuking the filter up under the dash somewhere.

The symptoms I am trying to fix is a slight surging at highway speed around 4000 rpm. Worse in gusty wind conditions.
Also picking the revs up slowly in neutral they take off at around 3000 and shoot up to 5-6000
Starts fine(warm weather here) pops a bit on decel, standard filter with prefilter, valves done, fuel pump Faucet, 95 octane, 42 pilot jets, Gualdi slip ons.

I was thinking of raising the needle, lowering the clip one notch. If this dosn`t work, I will try 43 pilots.

Also the TPS I will be checking. One of these things must make it better......and smoother. At around 5000 she buzzes quite a lot. I feel it in the footpegs, tank and seat. :(

How does that sound to ye of knowledge ?

Sporting Wood 11-22-2012 12:51 PM

Stock jetting? They tend to come lean at cruise rpm, 4000.

ALSO, I have a bag of those weird sized o-rings in viton. Anyone who needs any, let me know. I've sent a bunch of them out to folks here already. Price = free / owe me a beer. Send me a SASE, pm for address.:freaky

rossguzzi 11-22-2012 06:38 PM

As far as I know it is stock jeting. The mech that did the valves checked the jets, not me.

Incoming PM re o rings . Cheers.

Sporting Wood 11-22-2012 06:48 PM

Surging is most often a lean condition, but can also be vents, sync, a missing hose on one of the intake taps, pinched carb grommits or a loose carb boot. If it didn't do it prior to the wrench, somethings loose. If its not a fault with assembly, and it did it prior to the wrench, you've likely got f'd jetting...and if you're running the prefilter with stock settings thats likely your problem imho.

Head2Wind 11-22-2012 09:31 PM

7/32" vacuum hose (not fuel hose), front 11" and rear 10", will run down through the bottom airbox and terminate down next to the starter. Works well, 100s of 1000s of miles with this setup.


Quote:

Originally Posted by rossguzzi (Post 20097906)
Thanks for the info, one more thing......

Should I try to get the 2 carb vent hoses into a more 'still air' place than just under the air box? I have read doing a 2 into 1 with a small filter can cause probs. I was thinking of doing this and tuking the filter up under the dash somewhere.

The symptoms I am trying to fix is a slight surging at highway speed around 4000 rpm. Worse in gusty wind conditions.
Also picking the revs up slowly in neutral they take off at around 3000 and shoot up to 5-6000
Starts fine(warm weather here) pops a bit on decel, standard filter with prefilter, valves done, fuel pump Faucet, 95 octane, 42 pilot jets, Gualdi slip ons.

I was thinking of raising the needle, lowering the clip one notch. If this dosn`t work, I will try 43 pilots.

Also the TPS I will be checking. One of these things must make it better......and smoother. At around 5000 she buzzes quite a lot. I feel it in the footpegs, tank and seat. :(

How does that sound to ye of knowledge ?



Times are GMT -7.   It's 11:43 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014