ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Thumpers (http://www.advrider.com/forums/forumdisplay.php?f=15)
-   -   '12 KTM 690 Enduro rear tail light issue - tried searching (http://www.advrider.com/forums/showthread.php?t=851556)

SportsGuy 12-28-2012 02:07 PM

'12 KTM 690 Enduro rear tail light issue - tried searching
 
OK, so I noticed this when I dropped the bik eoff for the first service - the rear tail light was not operating.

The dealer said they "fixed" it as they noticed it too... guess again.

Two weeks ago I saw it was out on a quick 'round-the-block ride. I jiggled the bulb and it worked again.

Yesterday, it went out again. I wedged a piece of wood in to force the bulb slightly sideways in the socket, forcing contact and making light happen (wood now removed) for the ride home. But, it's just not working as it should. Push, twist and release - the bulb should now be in place on the spring loaded tangs, illuminating said bulb.

The springs force the bulb forward, as expected, but clearly contact isn't being made as the bulb remains unlit.

The mechanics of installing the bulb work fine for me, but there's a failure to make contact when the bulb is fully seated.

Any ideas on how to fix this? I *could* drop the bike into the dealer in the New Year (they're closed through next week sometime) and see if they'll warranty it with new parts, but everything is brand new (800 miles...) and works as intended. This leads me to think it's a POS design, so new parts won't really fix that... Plus there's the time involved to manage that process. :(

So, any other 690 folks seen this issue?

Assfault 12-28-2012 07:08 PM

The fix I see most 690 users doing is replacing it with the LED unit and never having to worry about it again.
Mine has held up with repeatable heavy abuse over rough terrain.
Sicass Racing makes some nice units with flush mount turn signals, very bright.
Do yourself a favor and ditch the stock POS.

SportsGuy 12-28-2012 07:44 PM

Quote:

Originally Posted by Assfault (Post 20348349)
The fix I see most 690 users doing is replacing it with the LED unit and never having to worry about it again.
Mine has held up with repeatable heavy abuse over rough terrain.
Sicass Racing makes some nice units with flush mount turn signals, very bright.
Do yourself a favor and ditch the stock POS.

I was actually researching those options earlier today, in fact. I am probably the one person on planet earth that likes the stock lights as they are...LOL I'll check out your recommendation. :)

SportsGuy 12-29-2012 10:59 AM

Still seeking feedback on this problem gang...

modeselector 12-29-2012 12:18 PM

Quote:

Originally Posted by Assfault (Post 20348349)
The fix I see most 690 users doing is replacing it with the LED unit and never having to worry about it again.
Do yourself a favor and ditch the stock POS.

What he said. You will discover when you take if off pavement, you will be replacing the wimpy bulb often.

SportsGuy 12-29-2012 02:18 PM

Quote:

Originally Posted by modeselector (Post 20352237)
What he said. You will discover when you take if off pavement, you will be replacing the wimpy bulb often.

I hear what you're saying, but my real world experience tells me different.

I have 800 miles on the bike now, over 300 of which is offroad. Bulb is just fine.

Not trying to be a doink here, as I also know that LEDs will last longer ultimately, so I know what you're saying makes sense. I like big, obvious lights, hence my desire to keep the factory gear in place. I may actually replace the bulbs themselves with LED bulbs, solving the broken element issues that'll happen eventually. But if the socket in the factory tail light is wonky, a new bulb won't cure that. :(

I'm trying to avoid shelling out another hundred bucks on a part I might not need given how I ride. This might be my problem... *sigh*

Yellow Pig 12-29-2012 05:10 PM

Anyone mounted a 500 EXC tail light:

http://t0.gstatic.com/images?q=tbn:A...bCsdvsmnb_AoL_

vs the XC-W tail light:

http://t0.gstatic.com/images?q=tbn:A...W2bEKi7FPMtAYw


Times are GMT -7.   It's 01:35 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014