ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Orange Crush (http://www.advrider.com/forums/forumdisplay.php?f=34)
-   -   Low temp thermoswitch for adv990 (http://www.advrider.com/forums/showthread.php?t=871229)

MrGee 03-16-2013 10:34 PM

Low temp thermoswitch for adv990
 
Hey wisdomer's,

My first post. :clap

I purchased the lower temp thermoswitch from Ktmtwins and installed it onto my new old stock 2011 adv990(white, if it matters), reason for the change was the bike seemed to get too hot before the fan kicked in.
Scenario: Went on a short weekend trip after I had done the first service at 1k Kms. Had my wife in back and luggage including top box but wasn't overloaded and the bike was fine until I got into a small town in traffic and got the speedo cluster flashing at me telling me it was too hot. Bike didn't shut down, I switched off the engine and waited till traffic started moving and fired up and went on my way short distance to the hotel. Once at the hotel and bike cooled, I checked the coolant level and all was good, even found a high enough concrete curb to elevate the front and burp the system and no visible air bubbles appeared and it did not take any additional coolant. This trip freaked me out and it hung in the back of my mind so much so I scrapped plans for riding the next day and just stayed around the town and returned home 300+Kms the next day. At this point I was kind of put off that a brand new bike would not have enough to cool itself in tropical weather. I calmed myself by telling myself the bike was just too new and still very tight and so generating a lot of excess heat. Once fully broken in it should be fine.
Now I'm approaching the 6k Kms mark and the heat issues seemed to stabilise, never had the cluster flash at me again but of course I have added or swapped to the Ktm Twins lower temp thermoswitch. Only problem is once the fan starts, it does not stop until I'm either moving or I shut off the engine. Ie: the fan does not cycle on and off at lights or in traffic, it just comes on and stays on. I've flushed coolant, replaced with engine ice and water wetter and even elevated by crane to 3ft to burp it and still no cake. I'm beginning to think the thermoswitch is just too cold a setting for the climate here which averages 30deg C most days. Is the fan running constantly going to affect the charging system in the long run and the life of the fan as well? I'm kinda stumped.
I've also added the second fan kit by Advmachines but unfortunately they did not ship the 200degF thermoswitch which I opted and paid for(still waiting on reply from them, they were nice enough to add shipping to my country but now seem to not want to reply to emails about their short shipment, looking to end up being a PayPal dispute). The install went great and the fan works well but alas due to the switch the fans turn on but don't go off or cycle unless I get moving, even whilst in the shade with a breeze going by they won't cycle. Should I put back the original thermoswitch just so the fans will cycle on and off?
Thanks in advance for your time and advice.

Nailhead 03-16-2013 10:46 PM

I installed the 160 in mine & the fan does run a whole lot more, but then that's its job & that's why I bought that switch: so the bike runs cooler.

FWIW, I simply removed the old one & screwed the new one quickly in with no particular burping rituals afterwards (beer excepted). A little coolant was lost, but I topped up the reservoir with what looked like an equivalent amount & went riding.

Check your reservoir level with the bike cool, top up if necessary, and let the fans do their work. That's what they're there for, especially idling stationary in Singapore.

Happy trails & welcome.

MrGee 03-16-2013 11:58 PM

Fan switch on the way.
 
Hey nailhead,
Thanks for reply, I know I should just let the fans do their work, just worried in the long run having the fans on constantly will bring on other issues with regulator overload. This bike is just so much fun, I guess I want to make it last as long as conceivably possible...:D

On a side note,

Just got a reply from Ken at AdvMachines, awesome guy, will be sending me the short shipped 200F fan switch ASAP.
Hopefully this temp combination will be the dogs balls for the climate here. Fingers crossed!

MrGee...

Nailhead 03-17-2013 03:10 AM

If those fans aren't on while you're moving, I'd leave it alone.

zeropoint 03-17-2013 06:22 AM

I have the BDCW aux fan on mine and I installed the thermostatic fan switch for a trip to Italy last summer. It was 35 degrees plus much of the time and I too found the fans were on too much as I was riding a lot of steep, slow, twisty climbs. The problem was compounded as the second fan, unlike the OEM, has no shield to divert the hot air away from your leg. I was roasting enough as it was without having constant hot air being blown right at my thigh. I swapped the OEM switch back. I had to top up with coolant a couple of times but the bike never overheated.

Perhaps a thermoswitch that doesn't trick the bike into believing the temperature is quite so high would be a good idea Say 9 degrees up rather than 17 ?

mikeegee 03-17-2013 04:09 PM

I, too, added a second fan kit and lower temp thermostat and found the fans running far too much. Before, the bike would get too hot, and after, the fans would run too much. Even when sitting in traffic and the ambient temp was below 50 the fans would run for extended periods.

Before long you'll get some smart folks on here who will chime in and explain the science behind coolant and temperature release and the cooling capacity of the bike (http://advrider.com/forums/showthread.php?t=855088).

Fact is, when I put the lower temp thermostat in, I felt the fans came on too early and ran too long for the cooling system to actually work effectively. Once I replaced the lower temp switch with the stock switch I found the fans came on when necessary and still cooled the system quicker than stock.

You don't want the bike to run cooler, you want it to run at the engineered temperature and cool faster when it gets hot so it doesn't run too hot. That and you want the fans to run for a shorter period of time reducing the impact on the charging system.

Nailhead 03-17-2013 09:46 PM

Quote:

Originally Posted by mikeegee (Post 20970050)
You don't want the bike to run cooler, you want it to run at the engineered temperature and cool faster when it gets hot so it doesn't run too hot. That and you want the fans to run for a shorter period of time reducing the impact on the charging system.

That makes sense.

Chuckracer 03-17-2013 10:28 PM

Quote:

Originally Posted by mikeegee (Post 20970050)

You don't want the bike to run cooler, you want it to run at the engineered temperature and cool faster when it gets hot so it doesn't run too hot. That and you want the fans to run for a shorter period of time reducing the impact on the charging system.

I agree.

MrGee 03-18-2013 10:07 PM

Updates...
 
So... after installing the second fan kit I went ahead and removed the KTM Twins 160F thermoswitch and put in the stocker.

After a couple of days with ambient temps or around 30-32deg C I'm pretty pleased to report that the combination seems to be ok. Have yet to be caught in standstill traffic just slow moving.

With this combo, it will get to about 3 bars from the top when the fans kick in and turn off at 4 bars from the top even after some hooliganism. Fan cycle times definitely a lot shorter than stock, cooling down much faster. (less load on charging system)

I'll keep monitoring untill i receive the 200F thermoswitch and give that a shot just for the sake of it but as of now, I'm pretty please with the Dual fan and original thermoswitch setup.
:clap


Times are GMT -7.   It's 07:13 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014