ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   GS Boxers (http://www.advrider.com/forums/forumdisplay.php?f=3)
-   -   Wethead - Euro LED signal swap (http://www.advrider.com/forums/showthread.php?t=884089)

oz97tj 05-02-2013 09:42 PM

Wethead - Euro LED signal swap
 
I didn't take photos of the bike apart, but here are a few photos. The rears were super easy and took maybe 10 minutes. The front was a bit more complicated. To get to the plug, you have to remove the side panels which is a pain in the butt due to all the fasteners but is fairly straightforward.

There is one problem though. The dash gives a lamp warning. I installed the lights the day before going in for my first service at the dealer with the intent of having them make the change to the computer to fix the lamp warning. Turns out BMW hasn't released the update in the software to allow this change yet. My dealer has contacted BMW about the issue and they believe it will be handled shortly. The option was available on previous bikes so should be available on this one as well, especially considering these are the Euro factory signals offered to the rest of the world.

Rear side by side...
http://i622.photobucket.com/albums/t...ps4492fee2.jpg
Complete...
http://i622.photobucket.com/albums/t...ps49bd7f1d.jpg

Front side by side...
http://i622.photobucket.com/albums/t...ps49d0c705.jpg
Complete...
http://i622.photobucket.com/albums/t...ps9edf10a3.jpg

Other than the lamp warning, the LEDs work great. They have given me extra horsepower and better fuel economy along with making women have the uncontrollable urge to show me their bewbs. Everyone should do this mod!:D

paulW 05-02-2013 11:36 PM

Quote:

Originally Posted by oz97tj (Post 21322051)

Other than the lamp warning, the LEDs work great. They have given me extra horsepower and better fuel economy along with making women have the uncontrollable urge to show me their bewbs. Everyone should do this mod!:D

That is an interesting and little known fact. Out of all the options, I like the third one best :evil

RichBMW 05-03-2013 12:40 AM

Much much better:clap

SS Twin 05-03-2013 07:10 AM

Love the look (of the "bulbs); now how about some pics of the "bewbs"? :evil

Seriously, it's a great look. How much for the led's? Please let us know how/when you get the update. Thanks.

oz97tj 05-03-2013 08:39 AM

Quote:

Originally Posted by SS Twin (Post 21323805)
Love the look (of the "bulbs); now how about some pics of the "bewbs"? :evil

Seriously, it's a great look. How much for the led's? Please let us know how/when you get the update. Thanks.

The LEDs arent cheap. They are like 45 bucks each. I ordered mine from Max BMW.

SS Twin 05-03-2013 05:57 PM

Thanks, not totally hateful, but then again they are "genuine BMW parts"! Hahah.

Let us know how the flash goes to eliminate the error message. Also, is everything good with the "mechanicals"? So far, no other serious reports of major issues other than yours.

paco fernandez 05-03-2013 06:56 PM

At Mexico since 2008 all bmw bikes comes with led turn signals as standard

http://img.tapatalk.com/d/13/05/04/9ese5upy.jpg


Enviado desde mi iPad con Tapatalk HD

oz97tj 05-03-2013 09:32 PM

Quote:

Originally Posted by SS Twin (Post 21328136)
Let us know how the flash goes to eliminate the error message. Also, is everything good with the "mechanicals"? So far, no other serious reports of major issues other than yours.

So far so good. I've done the 600 mile service on the new motor now with no issues. I took it to the dealer for the first service so they could look at it just to cover my ass and I figured they would give it a good look seeing as they've gotten so personal with it already. I'm pretty happy with it overall.

Quote:

Originally Posted by paco fernandez (Post 21328529)
At Mexico since 2008 all bmw bikes comes with led turn signals as standard

Those signals come on pretty much every bike outside the US. Supposedly our Department of Transportation says the LEDs don't have enough surface area so they don't meet their requirements. From what I understand, it has nothing to do with the brightness but rather the size. Makes no sense to me.

pfiedler 07-20-2013 02:27 PM

Quote:

Originally Posted by SS Twin (Post 21328136)
Thanks, not totally hateful, but then again they are "genuine BMW parts"! Hahah.

Let us know how the flash goes to eliminate the error message. Also, is everything good with the "mechanicals"? So far, no other serious reports of major issues other than yours.

Had a set of the LEDs installed at Max BMW today during my 600 mile service. The problem with the LAMPS warning is still not resolved despite the fact that BMW recently "released" the LED signal lamps to the dealerships after having them on "hold" due to this CANBUS/software problem. The tech hooked my bike up to the "mother ship" at BMW, but he and another tech were very frustrated to see that this problem has still not been resolved.

The GM and the Accessories Manager at Max's are going to contact BMW next week to see if they can find out when the software update will be available. Until then, I have to live with the yellow caution light and the LAMPS warning on the computer read out.

The LED turn signals flash quicker than normally, however work at the normal flash rate when operating the hazard lights. Supposedly, when the software silliness gets ironed out by BMW, the flash rate will return to normal. :rofl

I'll drop a note back to this thread once (if ever) this is resolved! You would think BMW would have fixed this by now. :lol3

Please ride safely!

Peter

oz97tj 07-20-2013 04:18 PM

Yup, I'm still waiting too.

def 07-20-2013 07:05 PM

Quote:

Originally Posted by oz97tj (Post 21329459)
Those signals come on pretty much every bike outside the US. Supposedly our Department of Transportation says the LEDs don't have enough surface area so they don't meet their requirements. From what I understand, it has nothing to do with the brightness but rather the size. Makes no sense to me.

There is little sense to be found in most everything our gov has been doing for the last 6+ years....and, it seems to be getting worse.

hammick 07-21-2013 09:08 AM

Quote:

Originally Posted by def (Post 21914865)
There is little sense to be found in most everything our gov has been doing for the last 6+ years....and, it seems to be getting worse.

Yeah let's blame the led blinker issue on Obama. Pretty sure we were all running led signals when Bush was in office.

JetSpeed 07-21-2013 10:49 AM

Quote:

Originally Posted by hammick (Post 21917841)
Yeah let's blame the led blinker issue on Obama. Pretty sure we were all running led signals when Bush was in office.


I say; Blame it all on that worthless piece of shit.


Nice blinkers by the way, I'll get a set as soon as the software update is released.

El Gato 07-21-2013 10:58 AM

Quote:

Originally Posted by oz97tj (Post 21322051)
The option was available on previous bikes so should be available on this one as well, (snip)

Love the look. FWIW - I did the euro LED swap on my '12 GSA, and no software update was required. It was a straight plug 'n play and they worked perfectly out of the box. Not sure why BMW felt the need to complicate matters on the new LC.

FixxiT 07-21-2013 01:38 PM

Quote:

Originally Posted by El Gato (Post 21918416)
FWIW - I did the euro LED swap on my '12 GSA, straight plug 'n play and they worked perfectly out of the box.

'13 GSA same deal, plug & play, no issues here :D


Times are GMT -7.   It's 08:49 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014