ADVrider

Go Back   ADVrider > Search Forums
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Showing results 1 to 5 of 5
Search took 0.00 seconds.
Search: Posts Made By: Dirt Virgin
Forum: Thumpers 06-15-2013, 11:10 AM
Replies: 152
Views: 32,344
Posted By Dirt Virgin
Bc

My electronic manual didn't work either. I went to the dealer and got one that did. It didn't have all that much more information. What you need is the factory service manual.
Forum: Thumpers 06-05-2013, 01:50 PM
Replies: 152
Views: 32,344
Posted By Dirt Virgin
Hey Folks I think I'm going to have to bring...

Hey Folks
I think I'm going to have to bring the TE back to the dealer for service. I thought it was just tight because it was new. After putting 40 miles on it, the engine still doesn't want to...
Forum: Thumpers 05-21-2013, 09:43 AM
Replies: 152
Views: 32,344
Posted By Dirt Virgin
OK kids here goes. You all seem to know more than...

OK kids here goes. You all seem to know more than the dealer. Followed your instruction and got the speedo to read in miles per hour. Having the dealer look into any recall issues. Now I'm trying to...
Forum: Thumpers 05-21-2013, 06:51 AM
Replies: 152
Views: 32,344
Posted By Dirt Virgin
I am going to speak with the dealer today and try...

I am going to speak with the dealer today and try to get a few questions answered. Hope it goes well. I'll let you know.
Forum: Thumpers 05-20-2013, 07:25 PM
Replies: 152
Views: 32,344
Posted By Dirt Virgin
Hello all New here. Just bought a new TE 310....

Hello all
New here. Just bought a new TE 310. Hoping to get information from those in the community. I removed the evap can and hoses before my first ride. Put a cap screw in the intake manifold...
Showing results 1 to 5 of 5

 
Forum Jump

Times are GMT -7.   It's 07:11 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014