ADVrider

Go Back   ADVrider > Search Forums
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Showing results 1 to 15 of 15
Search took 0.01 seconds.
Search: Posts Made By: BillW3
Forum: Day Trippin' 10-19-2011, 12:58 PM
Replies: 5
Views: 921
Posted By BillW3
Great video! Those roads look like a lot of fun.

Great video! Those roads look like a lot of fun.
Forum: Thumpers 10-14-2011, 01:10 PM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
On Hall's website, you have to remove the space...

On Hall's website, you have to remove the space in the part number. For example, for part number 1615 03601 (space between 5 and 0) you have to enter 161503601 (no space). Hope that was your issue.
Forum: Thumpers 05-27-2011, 06:38 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
I ordered mine from him this spring. Here is what...

I ordered mine from him this spring. Here is what was on the invoice. It looks like 10mm, to answer your question.

Handguard set, 86x38/40mm, - Powerlet
Lower Clamp Tall (2 1/2") - 10mm Bolt ...
Forum: Thumpers 05-26-2011, 08:46 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Thanks for the reply. Actually, I bypassed the...

Thanks for the reply. Actually, I bypassed the switch so I don't have to pull in the clutch to start. I did it when I added ASV levers, so, if I remember correctly, there wasn't a way to mount the...
Forum: Thumpers 05-26-2011, 08:42 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Ah, thanks! Just checked. When I turn on the...

Ah, thanks! Just checked. When I turn on the ignition switch the fan comes on. And now it is not starting. (Cranks over, doesn't fire.) I noticed that it has been taking a bit longer to start since...
Forum: Thumpers 05-26-2011, 07:26 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Flashing Neutral

My neutral light started flashing indicating a fault. Is there any way to troubleshoot this w/o having to buy the iBeat software? Thanks.

Almost forgot, it's a 2008 TE610. 8,xxx miles.
Forum: Thumpers 04-04-2011, 08:34 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
I haven't had to do it yet, but I have been...

I haven't had to do it yet, but I have been keeping the link handy for when I need it. http://www.advrider.com/forums/showthread.php?t=403478
Forum: Thumpers 02-24-2011, 04:06 PM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Clutch Basket Options

My clutch basket (clutch housing - 8000 A0371) is grooved from the clutch plates. (I already have it apart to replace the spring caps in the clutch.) The stock one is $321. Are there any other...
Forum: Thumpers 02-11-2011, 08:44 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Thanks Indy Unlimited. Sent you a PM.

Thanks Indy Unlimited. Sent you a PM.
Forum: Thumpers 02-11-2011, 07:22 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
That was timely . . .

So, I got my 610 last spring. Have been reading this tread daily since then. I hadn't really looked very closely at the motor other than routine maintenance, so I decided this winter was the time to...
Forum: Thumpers 09-13-2010, 08:08 PM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
I ordered one online from Hall's earlier this...

I ordered one online from Hall's earlier this summer. They have the parts catalog online.
https://www.halls-cycles.com/Catalog/Halls-Cycles-Husqvarna.aspx
They shipped it quickly, so must have had...
Forum: Thumpers 07-22-2010, 07:43 AM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
<!-- / message --><!-- sig --> Thanks...

<!-- / message --><!-- sig -->


Thanks guys. I will check for leaks and look into the Trailtech or other temp monitor. The temp numbers will be very helpful so I know what to look for.
Forum: Thumpers 07-21-2010, 08:35 PM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Can you give me more info on how you added a temp...

Can you give me more info on how you added a temp sensor? I would like to know for sure what it is running at. What temp range are you seeing? Thanks for the help.
Forum: Thumpers 07-21-2010, 07:04 PM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Hmmm. That's what what I was expecting. ...

Hmmm. That's what what I was expecting.




I checked the coolant level last night. Radiator was full. I added a bit to the overflow tank but didn't take much. Just checked it now that it...
Forum: Thumpers 07-21-2010, 05:46 PM
Replies: 26,555
Views: 3,657,287
Posted By BillW3
Radiator fan

I have had a 2008 610 for a little over a month and am getting used to how the bike works. It is in the 80's and humid today (central Iowa.) When the engine heats up after about 2 miles, the...
Showing results 1 to 15 of 15

 
Forum Jump

Times are GMT -7.   It's 03:52 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014