View Single Post
Old 08-11-2009, 10:55 AM   #52
TexasMule
Float away ya fairy...
 
TexasMule's Avatar
 
Joined: Jul 2001
Location: North of BIG D
Oddometer: 3,858
Trail Tech Lights....

Quote:
Originally Posted by Sutherngintelmen
Lost both lights within 6 hours of each other on Sunday ride. Not raining. Shipped them off to TT yesterday afternoon but bummed.

Spoke with Dave Petersen at BestRest and seems like failed ballast. You could see the lights trying to fire up but it was faint flicker then nothing. No rain during my ride - they had been in the rain a few weeks prior but seemingly without issue. Mounting was light up and post down on EZyMount.

I did have 'white oxidation' on the inside of the lens after first installing them (never went away) but it didn't seem to impact performance (which is superlative when they are on.)

Also - had some fading of powder coat turning hem bronze in color. Took a pick before crating will try to post later.

Need to tape / zip up wiring now prior to commute - disappointed to cut them off the bike yesterday.
Family just came back from a 4K trip across the US and one of Mulewife's TrailTech lights crapped out. (with no more than 10 hours of use) As stated above, both started to turn "bronzish". Spoke with TT and they said the anodizing on the first lights were defective. She sent both back for replacement. I was assured by TT that the anodzing will not turn on the new lights. We'll see.

So far, not terribly impressed by the TT lights.
__________________
TMule
You can buy everything, but more time...
______________________________________________
-to my mind alloy triumph tanks rank near titties in their inherent attractiveness -Mutt
TexasMule is offline   Reply With Quote