View Single Post
Old 09-17-2011, 07:07 PM   #23
Krasniewski OP
I don't ride much.
 
Krasniewski's Avatar
 
Joined: Feb 2008
Location: LA - Lower Alabama
Oddometer: 1,101
Tried another fuel pump, made sure the timing marks check with piston position and cam position. Resistance on the timing sensor seems to check out.

New coil sticks, new plugs.

Rechecked spark, injectors are spraying fuel. Spraying fuel down the intake with a spray bottle does almost nothing (got it to pop ONCE, could not duplicate). Once in a while it'll shoot flames up the intake - seems like spark isn't going at the right time. Plug wires are numbered, 1 and 2, so that's not wrong. Injectors are correctly hooked up as well, though I played around just for kicks - no joy.

Seems the spark is going at the wrong time - once in a while I can get flames to shoot up the intake. I tried a new ECU as a last ditch effort. Again, no change. I don't have anything to measure compression, but I can feel sucking and blowing through the intake and plug hole when the plug is out.


Ideas, anyone? I'm thinking about buying a fleabay wiring harness,but again, that's just desperately throwing money at the problem.

EDIT: If I open the throttle WFO - the injectors stop spraying. I wonder if this is supposed to happen, or if it's a TPS error of some sort. I dont' see anything about it in the service manual.



Krasniewski screwed with this post 09-17-2011 at 07:16 PM
Krasniewski is offline   Reply With Quote