View Single Post
Old 04-10-2012, 01:51 PM   #1
elioporky OP
Adventurer
 
Joined: Oct 2011
Location: Pittsburgh, PA
Oddometer: 31
1971 Suzuki T500 Titan Fuel Delivery Issues - Vacuum Petcock Valve

**MOVED FROM AIRHEADS (MEANT TO STICK IT HERE IN THE FIRST PLACE )**

Thanks for you all help, guys! You all are geniuses and I can't believe how quickly the 2nd gear trick worked to free the stuck clutch.

Now I seem to have a small fuel delivery issue. It runs and got me around the block no problem but I have a few questions:

1. When I got the bike, the vacuum hose from the intake to the petcock was removed at the petcock end and plugged. Do people commonly operate this bike with this sort of setup to compensate for a failing vacuum system in the petcock? If this is common, how perfect should the seal be? I'm pretty sure the vacuum hose has a hole in it so I'm prepared to replace it anyway. I read in the T500 shop manual that you're not supposed to attempt to fix the vacuum valve system in the petcock. What is your experience with this aspect of the delivery system?
2. The fuel lines on the bike as I got it were clear and of a larger diameter than the nipples on the carbs and petcock. To compensate for the discrepancy, little bits of rubber were placed on the nipples to make the clear hose fit. The seals seemed sketchy so I swapped out the clear hose for black hose of the proper diameter. Will this effect the flow of fuel into the carbs? If this is the case, what sort of adjustments do I need to make to make everything work as it should?

Thank again for all your help. I'll send more pics soon.
elioporky is offline   Reply With Quote