View Single Post
Old 10-13-2012, 06:29 PM   #163
Stagehand
+/- V TDSPP
 
Stagehand's Avatar
 
Joined: Oct 2004
Location: Shawangunks
Oddometer: 25,793
Quote:
Originally Posted by Dakar83 View Post
Two steps forward one step back!

After performing faultlessly over the 2 days of the off road course I washed the bike down and the next day went for a ride. About 3km from home the engine cut out, It restarted ok but started back firing a little then cut out again. Progressively this worsened until I couldn't ride any further. The bike starts easily and idles well, but when it's rolled off the centre stand or rocked back and forth it cuts out. No more backfiring it runs fine then cuts out as though the kill switch had been activated. As I say after each cut out it starts again fine.

I thought maybe some water had got in where it shouldn't be, fuel is fine, spark is fine so there must be a some electrical fault?
I left the bike for a day hoping it might dry out, but no change so I started checking out the connections. After an hour having checked and tightened all the connections I could think of and emptying both float bowls to make sure there was no water contamination. I try again but no luck. Now I'm stumped, any ideas?
ignition related, afterfiring would indicate no spark.
something cuts out when it gets warm, perhaps.
Not sure what ignition system its got, but do you have a spare known working ignition (bean) can to swap in? Or CDI controller, bolted to the bikes backbone? Seems like the problem comes from what is controlling the spark.
__________________
Unintentional psychokinesis.
Stagehand is offline   Reply With Quote