View Single Post
Old 10-23-2012, 11:07 AM   #23
vintagerider
Beastly Adventurer
 
vintagerider's Avatar
 
Joined: Nov 2005
Location: the west
Oddometer: 1,911
"rapid firing of injectors"

You mean that you hear a relay chattering?

Start at the battery. Clean/tighten terminals. The ground wire to the engine is a little tough to reach but that should be checked. Hopefully one of these is the culprit. Try supplying a temporary alternate ground pathway from the batt grond to a solid frame/engine ground.

On the 11xx you can (carefully) by-pass the ss switch and ignition sw sub harness then the kill switch. Those are common failure points. Swap the relays. Check the wire harness over. After that check the 02 heater wire. Beezer was more specific in telling you to unplug it along with the purge valve (located under the porter).

Chances are good that one of the above will resolve the problem. In the off chance that it doesn't there are other steps that an auto electric guy will take. Depending on your skills we can walk you through those. Because of the risk of frying the wiring harness I won't delve in to these just yet.

Regarding fuel pump relay getting power from key through the kill switch: Beezer is that just the relay coil? I don't have the 1150 schematic handy. I can say that I've had a fuel pump run continuously from a seized relay on a 2002 and I thought that was with the key off. That would imply that
only the relay coil is key and switch controlled which is typical.
vintagerider is offline   Reply With Quote