View Single Post
Old 11-14-2012, 07:38 PM   #2
ebrabaek
Beastly Adventurer
 
Joined: Jan 2010
Location: El Paso,NM
Oddometer: 4,587
Quote:
Originally Posted by Tebpac View Post
A friend has a 2011 650 GS that he purchased in late 2010. This year, we were finishing a ride and stopped at a buddies camp for grub. When we came out, the 650 would turn over but wouldn't start. Tried fresh gas. No go. It wouldn't even really try to start. Took it to the dealer. The checked the fuel system and felt it was bad gas that clogged the injectors. However, it happened again just recently on another planned ride. We rode about 90 miles and stopped to pick up another guy. Just before getting there, the bike stalled while in gear. He coasted it and it started up on the 3rd attempt. Stopped to pick up our other rider and the bike refused to start. Turned over everytime, but not a hint of it trying to go.........Are there any electrical issues out there for the 650, or other thoughts of what it might be. It now sits at the shop and they are looking deeper into it and contacting BMW....
This is the twin 650...yes...??? Have you tried Techron.....????? This is a known issue when the injectors gets clogged. There have also been a string of bad fuel pumps.... Look up " guzzimike" he just posted a pump thread. I would start with techron .... 1 oz per gallon, for a few tank fulls. Joel once said , that if the injectors are plugged bad, techron cannot help.
__________________


Erling
ebrabaek is offline   Reply With Quote