View Single Post
Old 12-04-2012, 06:24 PM   #1
Queen of Spades OP
tall drink of water
 
Queen of Spades's Avatar
 
Joined: Mar 2009
Location: Decatur, GA
Oddometer: 749
Eh? KTM 640 - engine randomly dies

Started a couple weeks ago on the way home. The bike was properly warmed up and out of nowhere - died at a traffic light. A couple presses of the Magic Button and she fired up and drove home the rest of the way.

Yesterday I went for a play ride and the bike again stalled just as I was getting onto 285. Like before a couple stabs at the MB got things going again. The bike ran fine the rest of the afternoon - logged about 40 miles, 10 of that woods trails including a couple creek crossings. Not a whimper.

Obligatory trail pic:


This morning on my way in to work, the bike stalled again after coming to a stop sign. This time it was a little harder to get going. A couple minutes later it finally lit up, and I rode the rest of the way to the office without a problem.

Tonight, again at a red light, the bike inexplicably died. I pushed to the side of the road and continued trying to get it to light up - nothing doing. I had no tools so I couldn't do any troubleshooting. I paged a taxi and after going home to get my pickup, the bike started right up.

Loaded it up and when I got home, I unloaded and again started it up - it ran fine for about 30 seconds, then died. Wouldn't start again.

WTF is going on?
__________________
'99 KTM 640 LC4 Enduro http://www.youtube.com/watch?v=fifXkDQpda4 (January 2014 snow ride)
Queen of Spades is offline   Reply With Quote