View Single Post
Old 12-22-2012, 11:06 PM   #1
ngng OP
Adventurer
 
ngng's Avatar
 
Joined: Jun 2012
Location: Cupertino, CA
Oddometer: 65
Fed up with my xenon related LAMPF, PDM60 installed!

Been in and out of town, finally had some time between flights to wire up the PDM60 I bought from Rocket Moto months ago. The primary reason I wanted this was to do away with fuses and to confidently power my DDM xenon kit, which of course is throwing a LAMPF. My secondary reasons for installing this unit is because in the past, with my cars, I've run far too many relays. The idea of a single wire and no relays sounded great to me! Ultimately, I plan on adding a set of xenon fogs, a 12V powered USB hub, and some other misc electronics.

From the time the 12v source is activated, i.e. key turned on, the PDM has a 6 second delay before activating all of its circuits. It appears this version allows you to aggregate two circuits for a larger capacity, so two 5 amp circuits can run in parallel as a 10 amp circuit. Even though a single DDM ballast hits 6A on startup, I am able to run it off a 5 amp circuit without any issues.

Sorry for the crappy photos, I snapped the off my iPhone.


Tapped the blue/green wire off the diagnostic port for my switched 12v+


I have the PDM60 sitting above my battery right now; when I have some more time I'm going to relocate it below the OEM toolkit.


Everything working!
__________________
06 DRZ400SM | 07 Race R6 | 08 1198S | 09 R1200GSA

…and those are just the bikes
ngng is offline   Reply With Quote