View Single Post
Old 01-06-2013, 05:54 PM   #3219
DriftDragon
Wanderer
 
DriftDragon's Avatar
 
Joined: Jun 2012
Location: Soddy Daisy, TN
Oddometer: 198
How long did you leave the Iceair on with the aftermarket pipe? I wonder if the ecu needed more time to adjust itself with the two together?

I have a akrapovic slip on on my 07 1200 and the difference was substantial. It may be your older electronics can't adjust for the pipe and you need a power commander to tune things manually for the pipe?

Quote:
Originally Posted by YetiGS View Post
I've had an interesting experience. Right after I got my bike ('97 1100GS) I bought a Leo Vince exhaust and have ridden that way since. I also did a jumper in place of the CCP, 30-87a.

When I got my IICE Air, I didn't notice a huge improvement. A bit smoother off idle and low throttle, but that's it. I also noticed my mileage was shite.

Yesterday I put the stock exhaust back on to see if it would help the mileage. I have no clue whether it will help the mileage, but DAY-UM!! The bike is now soooo much smoother and has a LOT more low end power. I was really surprised.

I set the IICE back to the "zero" setting and it felt fine, but lost a bit of pep. Put it back to -20 and it's got ZIP again.

I was really surprised by the improvement going back to the stock pipe made, but even more impressed by the amount of difference the IICE makes with the stock pipe.
__________________
DriftDragon
--------------
2007 BMW R1200GS Adventure

2003 KTM 525 EXC RFS
DriftDragon is offline