View Single Post
Old 01-14-2013, 10:27 AM   #3141
SoilSampleDave
Beastly Adventurer
 
Joined: Jan 2005
Location: The Delta Ghetto, GA (aka PTC)
Oddometer: 1,660
Quote:
Originally Posted by djhartm View Post
I have a 2013 500 EXC & followed the desog instructions verbatim yet am still getting popping & backfiring on deccel. I have placed bolts in both openings & used high-temp RV sealant and Locktite. I have removed, inspected, and reinserted numerous times and still cannot get rid of that confounded popping! I've also had a competent mechanic friend double-check everything.

I do have the stock/mild/wild map switch installed (pops under all modes) and an FMF MegaBomb/RCT4.1 combo. Bike also stalls a lot in first gear despite moving the idle-adjust knob several clicks counter-clockwise.

I am pretty frustrated. :(

On a side note, I ordered the KTM billet check-valve for the gas cap, and noticed that it was missing during a ride yesterday. I am assuming that the tank pressurized during use & blew the valve off (the small hose was still connected). Since the valve only allows are to enter the tank, not exit, how would this not happen again? I don't believe there are any other vents on the tank to allow vapors to escape.

Help!!!
If you still have the stock ECU map in your bike, it will ignore the map switch; correct? Get the unrestricted "Euro" map installed by the dealer.
__________________
Don't drive like my brother!

'13 350EXC-F
SoilSampleDave is online now   Reply With Quote