View Single Post
Old 01-21-2013, 12:25 PM   #327
biensur22
Gnarly Adventurer
 
biensur22's Avatar
 
Joined: Oct 2011
Location: San Diego, CA
Oddometer: 179
Quote:
Originally Posted by hondahawkrider View Post
need a little help from everyone..Awhile ago, I picked up a EGS-E , unfortunately it had spent some time oustide... I went to try and clean it up, but life intervened.. See this for the orig posts

http://advrider.com/forums/showthread.php?t=271534

Anyway, thanks to some help (especially JT Motorsports in frederick MD) It's alive.... It runs



It's had the old ST pipes replaced with EU set I got off here, amongst some other stuff..

Anyway, the spokes are being being redone, which is about the last item but for one thing....

The Tripmaster speedo has failed... The lights come on for the options, but the display is dead.... I need to find a source for a replacement or to fix the one I have... help
TT used to do an exchange for a refurbished one, but I think that ended several years ago. Mine stopped recording new miles, but after replacing the primary battery it seems to be functioning find. I think your first step is to take it apart and see if you can find a mfg part# on the screen itself. Or take it to an electronics guru and see what they can work up.

There's a long history of problems with the stock tripmaster display, from y research it seems most people have just converted to a trail tech dash as it fits well in the tripmaster spot.

Good luck!
__________________
Current Rides:1998 KTM 620 Adventure

Past Rides: 1994 KTM 400 EXC WP/D LC4 - Plated; 2001 BMW F650GS Thumper; 1970 CB175; 2003 KLR250
biensur22 is offline   Reply With Quote