View Single Post
Old 02-22-2013, 11:39 PM   #7
Beezer
Beastly Adventurer
 
Joined: Oct 2004
Location: Anchorage, formerly Spenard (hub of the universe)
Oddometer: 5,271
I put a set on my GS a few years ago. I screwed up and let them drill the mounting holes (for free, promotion). the holes were about double the size they needed to be. plus the aluminum was pretty soft. they were fine until I got to about mile 60 of the first gravel road I ran (McCarthey) & then they were so loose on the rack I thought they were going to fall off. the alu sides were distorted too.


look at the size of the holes they drilled!
(the little ones are mine... I started work before taking any pix & then thought better)



I riveted in a strip to reinforce the hard points & redrilled:


they have been fine for many miles.... like 20k... and they don't leak. on the other hand, other bits I got from them were a bit funky as well.... the racks, the turn signal relocate bar, the kit to drop exhaust. the mounting holes were too big & still did not always align. the turn signal thing did not work at all. anyway, point is that the construction is not on par with Jesse & such, but then they are half the money.

the bottom bracket holes I drilled big enough insert a washer. this brought the hole back to the right size. then a wide area washer on the inside to capture that one. the bottom was stiffer because of the side walls & didn't need the reinforcement. who knows... maybe I got the only funky one they ever made

Beezer screwed with this post 02-22-2013 at 11:49 PM
Beezer is offline   Reply With Quote