View Single Post
Old 03-24-2013, 11:31 PM   #25054
fritzcoinc
Enjoying my last V8
 
fritzcoinc's Avatar
 
Joined: Apr 2008
Location: Cypress, Tx
Oddometer: 6,488
Quote:
Originally Posted by jrusto View Post
I just bought a 2008 610 from my brother. Took it on a 80 mile shake down before I bought it and all seemed fine. A week later took it out for a 15 minute run and again all seemed fine until I pulled back into the carport when the bike would not idle and killed. Started it again but it would not idle. Started it again and it back fired and would not start. Kind of went over some things but with out even an owners manual I did not know where to look. Talked with my brother and found that it would not start with him after running fine on a trip to Colorado. He changed the fuel pump and it started back up. He told me that the battery might be old so I put a new battery in.

After installing the new battery, I tried to start it again and after a turning over a bit it back fired and then started but again would not idle. It started a couple more times and now will not start. I am new to four strokes especially with EFI systems.

I am not a total novice in motorcycle repair having worked my way through college at the now defunct Husky Dealership in the early 60 as well as wrenching on my sons Motocross efforts for a few years.

Any ideas on where to start would be greatly appreciated
Water in gas is a possibility.
Then pull plug, check for spark.
Check kill switch.
Check clutch or side stand safites ( if it has them )
Check fuel pump displacement ( is it pumping gas )
squirt gas in the intake while cranking to see if it will fire.
The usuall stuff. I doubt the service manual would be much help and probably does not have a trouble shooting section. If it did it would be a some wierd translation of Itialian.
__________________
Regards
Fritzcoinc
96 XR650L, 96 Guzzi Sport, 07 BMW K1200GT,
86 Husky 400 XCE, 00 Husky Te 610 e, 1999 Husky TC610 SM, 2000 Cagiva GC; Google: TX7
fritzcoinc is offline   Reply With Quote