View Single Post
Old 03-25-2013, 05:20 AM   #32
gravityisnotmyfriend OP
Studly Adventurer
 
gravityisnotmyfriend's Avatar
 
Joined: Jun 2012
Location: ((kg*m)/s^2), IA, USA
Oddometer: 947
And, of course, when I say the text is plain black - I mean black in the post box. It's whitish gray text obviously. Anyway, the project is stalled until I can get my throttle cable. But, there was the issue of the turnsignals.


The flasher relay box has a couple of cracks in it. No idea how that happened, but the signals did flash occasionally. But, it's just a little circuit board in a box. Flasher relays for cars are around $15. I'll just grab a new one. I checked out the parts fiche, looked up the part number...

It was over $100.

Now, in the state of IA, the rules are that if you have turnsignals on your bike they have to work. But, you don't have to have turn signals. So, for $120, I'm thinking I'll just pull the damns things off and call it good. But, I figured I'd open up the flasher relay and have a look to see if I could fix it myself. What do I got to lose?

So, I popped the case off the board and here is what I see:



The long oval is around a section of conductor that seems to have become de-tinned. The more circlish oval is around an obviously bad solder joint. This looks promising! So, I get out my tools and put some heat and fresh solder to it:



I should have taken another picture after I cleaned up the flux. But, I snapped the cover back on the put it on the bike.

Works perfectly. The signals signaled every time. I couldn't get them to not. Perfect! One more thing off the list.

The sad thing is that if the relay had been cheaper - I wouldn't have bothered. I woulda just thrown this one in the land fill and paid for a new one. I'm glad I took the time to inspect it.







Here's the list. Plain white is yet to be addressed. Green is repairs in progress. Yellow is done.

Rear tire - mount a meatier off road tire to replace the 80/20 street tire

Throttle cable - shot, needs replaced

Clutch – adjust



Spark plug – New one will go in after checking valve lash.







Turnsignals – bad solder joint resoldered

Sprocket Shaft Seal Leaks - seal installed

Valves - lash set

Instrument lights – bulbs replaced

Waterpump – rebuilt.

Headlight – flickers
Just a loose connection.


Tail light – doesn’t work
Handlebar wiring was redone - poorly


Parking light – doesn’t work
Parking light deosn't exist. Need to buy a replacement.


Rear shock – shot
Replaced


Carbs – jetted too fat
New jets ordered. 195-170MJ; 52-45 idle jet.


Seat – I hate the white seat
Painted with vinyl interior paint. Not lasting very well.


Luggage – none
Luggage rack built. Top box acquired - but I need to mount it.


Handlebars – too low
Rotated back too far. Moved them forward and I think It'll work


[COLOR="yellow"]Steering - spooky at highway speeds.
Steering stem had too much slack. Tightened her up.
gravityisnotmyfriend is online now   Reply With Quote