Thread: Clutch troubles
View Single Post
Old 04-08-2013, 01:48 PM   #1
Unruled OP
950S
 
Unruled's Avatar
 
Joined: Sep 2012
Location: Drugs, wooden shoes and windmills
Oddometer: 112
Clutch troubles

Hi guys,

I've had a 950S for a while now (2003, first European year) and am quite content indeed. It does have one small issue though, being the clutch. I know that KTM threw a wobbly when they designed the thing, and it's a weak spot. But I can't seem to find exactly where the problem is located and what's needed to fix it. I need the bike every day and can't (time-wise) afford to take it apart, assess damage, put back together and fix some other time.

Symptoms are limited to a very snappy clutch when the engine is cold. There is no vague feel (slave has already been replaced... by new original unit, but functions fine) and it completely disengages, doesn't slip when engaged.

However, when riding away with a cold engine I have to feather the throttle and ease the clutch out carefully, otherwise it lashes back, whips the chain rather uncomfortably (chain tension is set correctly) and I'll be lucky if the engine doesn't stall in the process (northern Europe, it's around freezing point here in the mornings, so cold means cold). Problem seems to be getting worse the past 2,000km (1,200mls).

Is the unit completely shot or is it a simple fix? Haven't checked the oil jet yet, but surely it can't be just that...
__________________
If you can't fix it with a hammer, you've got an electrical problem.
Unruled is offline   Reply With Quote