View Single Post
Old 05-08-2013, 07:35 PM   #46
tmlee
Enigma
 
Joined: Oct 2009
Location: Rhode Island
Oddometer: 522
Quote:
Originally Posted by BillDRZ View Post
I was able to find Spectrol 10w-50 so thats what went in, rather pricy at $16 qt. The bike has a drain plug with magnet which had a little black on it. I'm guessing typical breakin no metal shavings. I wasn't able to get the oil sump hose fitting off it's a 12mm I think and my wrench seemed to want to strip it so I'll pick up a new 12mm for the task. I wanted to look to see if there is a pickup screen behind the fitting that needs cleaning!
Does anyone knows on the 2013 model if this screen exists?? (still haven't recieved owners manual) I'm also trying to purchase the shop manual but Husqvarna isn't replying to my dealer, maybe lag due to new ownership. Pretty quick easy job maybe took one glass of wine (too cold for beer still snow on ground).
I just did the first oil change on my new 2013 TE310R and there -is- a finger strainer in the oil pan behind the sump hose fitting. I didn't think it was in there, but a little probing with the short end of an allen wrench (metric, of course ) and it popped right out.

It's cylindrical in shape, the diameter of the hole, and about 2" long. There was a little crud stuck to it so I am glad I pulled it. I washed it clean with a few squirts of brake cleaner.

The magnetic oil drain sump plug just had a very small amount of black on it.
__________________
Two roads diverged in a wood, and I --
I took the one less traveled by,
And that has made all the difference.
- Robert Frost
tmlee is offline   Reply With Quote