View Single Post
Old 06-17-2013, 03:27 AM   #10
Colonial Mick
Nettle Licker
 
Colonial Mick's Avatar
 
Joined: Mar 2009
Location: Upper Cumbucter West. Armidale/Kempsey Rd.
Oddometer: 2,409
Quote:
Originally Posted by Dee Cee View Post
Well where to start ( no pun intended ).

I've had a 2003 640 Adv for about seven years and 60,000 Klicks and it has always been a battle of sorts to start. I have long since got the knack to kick her with my left leg which felt awkward at first, like using your other hand to clean your teeth. For a bike that I enjoyed riding so much it really started to piss me off.

So decided to fix her and I have done just about everything you can think of.
After initially going thru a couple of batteries including the expensive Yuasa YTZ 10S I settled on a slightly larger Deca which I had to modify where my regulator sits to fit it in, then I stripped all of the start circuit out and checked and cleaned every thing and put back, I ran an extra earth wire direct from the battery neg to ground on the actual starter, I removed the starter, stripped it and found it pretty sad inside, so new brushes made up at the local auto elect and there is a little bush at the non driving end of the starter that dries out so it was greased.

Then out with the sprag clutch and replaced it as it was looking a little old.

I tried all sorts of starting techniques over the years and the only thing left as far as I could see was the auto deco on the cam must be dodgy. So out with the cam and I spent about an hour rolling it around in my hands until I understood how it works, very nifty I must say. Once I did this I could see where the weakness was in the design. I spent about 5 hours with emery tape and a small file increasing a little shoulder that allows the deco to do its job and BINGO all the other work came home to roost, now she starts like it should. These things have a shitty auto-deco in them from the word go and I am not sure how long my repair will last either. The cabie come fuel system doesn't help either as the fuel is fed by a vacuum pump and the carbie has no pumper in it to give a squirt to richen it up before a cold start. My mate has a 625 and his fires up well all the time. I am about to put a 41 mm FCR carbie on her so I will be most interested to see how starting is after this. Even now when cold the bike needs to wind over well for longer than I would like and I blame the fuel system for this and before I fixed the auto deco it would just take too much out of the battery to get the fuel through and to fire the ignition circuit with some grunt but now it starts just fine. I am hoping the new carbie will shorten crank time when cold.

In its present state the bike starts instantly when warm and I mean instantly.

All of this happened slowly over the last six years.

I hope it is of help to you.
Well done you have a lot of patients Dee Cee .I know the feeling when you suceed its a great sence of achievement !
__________________
"Be who you are and say what you feel.
Because those who mind don't matter
and those who matter don't mind".
.. -.-. --- ..- .-.. -.. -. .----. - --. .. ...- . .- ..-. .- - .-. .- - ... - .. -
Colonial Mick is offline   Reply With Quote