View Single Post
Old 08-22-2013, 01:21 PM   #1
Bumpaman OP
Gnarly Adventurer
 
Joined: Oct 2009
Location: Foot of the Sangre de Cristos and Music City, TX.
Oddometer: 154
Help with a 950 please

I have put this out before, but my problem still exists and I cannot seem to solve it. I have a 2005 950 A S model with 30K miles that really has been a trouble free machine. During the winter I did a water pump rebuild and a valve clearance check. Valves were in spec. When I rode the bike in june, I noticed a miss or a hesitation between 4k and 5k rpms that I have never noticed before. It will run smoothly from 4 to 5k while running up through the gears until you hit 5 and 6 then the hesitation/miss becomes noticeable. I have changed the fuel filter, it has a Facet pump that seems to be delivering alot of fuel, the stick coils and their attaching wires are plugged in well. all other wiring seems to be plugged in. I have had the carbs off and have gone through them cleaning passages and jets. I did a throttle body sync with a flowmeter and a twinmax. I thought maybe it was running to rich so I moved the needle up a notch to position 2, but this seemed to make the problem worse. So then I moved the needle back to position 3. This is were it has been since I put a jetting kit from ADVmachines and where they recommended it for my altitude and the bike has run perfectly for a couple of years in this position, until now. The moving of the needle would indicate that it is running lean, but how would this happen just sitting there in the garage????????? Anyone else have any ideas ????????? Any help would be appreciated. Thanks
Bumpaman is offline   Reply With Quote