ADVrider

Go Back   ADVrider > Bikes > GSpot > GS Boxers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-25-2013, 08:09 PM   #1
GS Yinzer OP
Go Stillers
 
GS Yinzer's Avatar
 
Joined: Feb 2013
Location: Pixburg, PA
Oddometer: 35
R1150GS in the Rain looses ABS / Check Engine LIght

Hey Guys.... I've recently picked up a 2003 R1150 GS with ABS Brakes. Every time I ride home in the rain, my check engine light comes on. A couple of times the ABS Brakes failed as well.

Any comments?

Thanx
GS Yinzer is offline   Reply With Quote
Old 04-25-2013, 10:21 PM   #2
hootch
Gnarly Adventurer
 
Joined: Jun 2007
Location: Wenatchee, WA.
Oddometer: 231
Electrical?

Sounds like an electrical connection to me. Pull the tank and clean/grease with dialelectic grease. While you are there, bleed the fluid from the ABS unit. There are instructions posted on this site, but basically it is the two bleed valves on the top of the unit. I always bleed the lines to the brakes first, then the ABS, that way I know that it is getting clean fluid. Be sure to check the condition of the lines. I just replaced all the stockers with braided stainless. Much better, and I was just starting to get tiny black specks in the fluid from the lines breaking down. It seems that 00-04 have that problem. $185 from Cyclebrakes and an afternoon made it all better. Have fun!
hootch is offline   Reply With Quote
Old 04-25-2013, 11:48 PM   #3
Beezer
Beastly Adventurer
 
Joined: Oct 2004
Location: Anchorage, formerly Spenard (hub of the universe)
Oddometer: 5,372
agree with the above.... except for one thing,,, if you still have the original rubber lines replace them before you bleed the brakes. rubber lines of that era are coming apart inside and polluting the system
Beezer is offline   Reply With Quote
Old 04-26-2013, 05:12 AM   #4
Rockmuncher
Studly Adventurer
 
Rockmuncher's Avatar
 
Joined: Apr 2010
Location: Western Canada
Oddometer: 760
I think the '03 had the servo abs, bleeding is a little more involved than the others but still not that bad. If it has 4 (I think) bleeders on the abs pump, it's a servo unit. Does it make a wizzy noise when you apply brakes?
I would also look at the wiring harness around the ignition. They tied them too tight and some of the wires might break. There is also a couple of unfused circuits you might want to protect too.
http://www.advrider.com/forums/showt...hlight=unfused
Rockmuncher is offline   Reply With Quote
Old 04-26-2013, 11:20 AM   #5
GS Yinzer OP
Go Stillers
 
GS Yinzer's Avatar
 
Joined: Feb 2013
Location: Pixburg, PA
Oddometer: 35
GS Whizzy Brakes

My GS has the Wizzy Brakes. I also see it still has the original brake lines as well. I plan on ordering up some new lines regardless to swap out the original. My neighbor has a bitchin garage. He should be able to help me out with the ABS / Whizzy Brakes and Bleeding.

Once I get these swapped over, I'll let you know how things go come first ride in the rain.

BTW: will the check engine light come on when the battery gets low as well?

THanks again for all of your help / knowledge.
GS Yinzer is offline   Reply With Quote
Old 04-29-2013, 06:24 AM   #6
Rockmuncher
Studly Adventurer
 
Rockmuncher's Avatar
 
Joined: Apr 2010
Location: Western Canada
Oddometer: 760
Get the funnel from Beemer Boneyard to do the bleeding, helps a lot. Speedbleeders are good too.
Not sure about the check engine light with low battery. Low battery makes the ABS light go on though.
Rockmuncher is offline   Reply With Quote
Old 05-04-2013, 07:03 PM   #7
slartidbartfast
Love those blue pipes
 
slartidbartfast's Avatar
 
Joined: Dec 2003
Location: Southern Louisiana or Southern England or ...
Oddometer: 4,792
Quote:
Originally Posted by GS Yinzer View Post
Hey Guys.... I've recently picked up a 2003 R1150 GS with ABS Brakes. Every time I ride home in the rain, my check engine light comes on. A couple of times the ABS Brakes failed as well.

Any comments?

Thanx
None of the other responders have thought to mention that the 1150GS doesn't have a "Check Engine" light.

Maybe your alternator belt is loose so it slips when wet and the charge light is coming on? Which light is it exactly?
__________________
MSF Ridercoach IBA: 35353 95 R1100GSA, 93 GTS1000, 85 R80RT, 93 DR350/435, 99 RX125, 78 DT100
January 2010 New Zealand South Island ride
Summer 2009 UK to Alps ride
Summer 2008 UK End-to-End ride
slartidbartfast is offline   Reply With Quote
Old 05-04-2013, 07:13 PM   #8
Ragin Rabbi
Semper Fidelis
 
Ragin Rabbi's Avatar
 
Joined: Sep 2006
Location: Western Maryland
Oddometer: 4,950
Quote:
Originally Posted by slartidbartfast View Post
None of the other responders have thought to mention that the 1150GS doesn't have a "Check Engine" light.

Maybe your alternator belt is loose so it slips when wet and the charge light is coming on? Which light is it exactly?
I'll bet it is the red exclamation point light beneath the break light on the gauges. If so, that too is a break failure indicator light, no?
__________________
Each according to their need, each according to their ability.

It takes a village to raise a child.

Go You Spurs!!
Ragin Rabbi is offline   Reply With Quote
Old 05-09-2013, 05:29 AM   #9
GS Yinzer OP
Go Stillers
 
GS Yinzer's Avatar
 
Joined: Feb 2013
Location: Pixburg, PA
Oddometer: 35
the light

it's the triangle / explamation point light. i will be calling beemer boneyard later today to get the funell tool. my new brake lines should be here in the next day or so. regardless, the brake lines are in need of an overhaul, and new brake juice is never a bad thing.

i have to change the bulbs in my speedo / tach. once inside, i will check for busted insulation.

thanks again...
GS Yinzer is offline   Reply With Quote
Old 05-09-2013, 07:07 AM   #10
slartidbartfast
Love those blue pipes
 
slartidbartfast's Avatar
 
Joined: Dec 2003
Location: Southern Louisiana or Southern England or ...
Oddometer: 4,792
Quote:
Originally Posted by GS Yinzer View Post
it's the triangle / explamation point light. i will be calling beemer boneyard later today to get the funell tool. my new brake lines should be here in the next day or so. regardless, the brake lines are in need of an overhaul, and new brake juice is never a bad thing.

i have to change the bulbs in my speedo / tach. once inside, i will check for busted insulation.

thanks again...
Ahah! It's actually a brake failure light coming on when you ride in the rain, not a check engine light at all. Check the wiring to and from the wheel speed sensors for any chafes or nicks. Check the plugs those wires connect to under the tank and (probably) along a frame rail somewhere on the rear of the bike. If you have a friendly dealer nearby, they can hook up to their diagnostic computer and probably pinpoint the circuit causing the trouble.
__________________
MSF Ridercoach IBA: 35353 95 R1100GSA, 93 GTS1000, 85 R80RT, 93 DR350/435, 99 RX125, 78 DT100
January 2010 New Zealand South Island ride
Summer 2009 UK to Alps ride
Summer 2008 UK End-to-End ride
slartidbartfast is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:53 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014