ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-05-2014, 09:13 AM   #1
hotrdd OP
Adventurer
 
Joined: Jan 2014
Location: Calgary, Alberta
Oddometer: 74
A breakdown, a cowboy and a matchless owner. Seriously.

I couldn’t make this up. Yesterday while leaving work in downtown “cow town” Calgary my 2005 KTM 950 S stalled at a light. I tried to restart it but the only way to even get even a little life out of it was to gingerly play with the throttle. But there was no way I was going anywhere. I rolled the bike to the side of the road where there was a small cal-de-sac. Jumped off the bike and called my friend to see if he was around with his truck. Just happened that he was about three blocks away, leaving work J So I started looking for a ditch or hill that we could use the bike when a fellow watering his grass asked if he could help me. So I asked him if he knew of a good loading spot. He had a better idea. How about I use the ramps for his motorcycle J Turns out he has a very, very old 1950 something matchless that he showed me that unfortunately was damaged in the floods last year but would defiantly be restored.
So there I am within 10 minutes with a truck, ramps and a new friend. Ready to load the bike up when a cowboy is wondering down the street and asks if he can help? SURE! So we line up the bike and I give the 3 count. 1… 2…. And before I could say three the bike is already in the back of the truck. So now I have a broken bike… but some cool new friends and a story to share.

THE BIKE had been sitting in the underground parkade of my office for a few days and the battery was dead. So I threw it on the trickle charger for the day while I was at work. When I went down after work the bike fired up just fine and I drove off. It wasn’t until a dozen or so blocks later that the bike just stalled at a light. And then would start but only if I played with the throttle. I suspect either fuel or electrical and am about to go out to the shop to start doing some testing.
Any suggestions where to look and what to test?
hotrdd is offline   Reply With Quote
Old 07-05-2014, 09:53 AM   #2
hotrdd OP
Adventurer
 
Joined: Jan 2014
Location: Calgary, Alberta
Oddometer: 74
so now I'm more scared. Went out to look at the bike and while cranking it over it was doing the same thing as yesterday. It would "kind of" start and idle. But any throttle and it would stall. So I thought maybe fuel. So I added a 1/2 gallon to each side which topped the tanks up. Then cranked it again. FINALLY it started running. Then after a minute of idle I was able to grab the throttle and its running normal.

so now what do I do? I don't need another breakdown. But how do I test if its not acting up ��
hotrdd is offline   Reply With Quote
Old 07-05-2014, 11:23 AM   #3
renogeorge
Beastly Adventurer
 
Joined: Apr 2007
Location: Reno
Oddometer: 1,182
Fuel Pump??
__________________
KTMs--300, 518, 990
renogeorge is online now   Reply With Quote
Old 07-05-2014, 11:54 AM   #4
spafxer
Beastly Adventurer
 
spafxer's Avatar
 
Joined: Mar 2007
Oddometer: 2,565
Quote:
Originally Posted by renogeorge View Post
fuel pump??


+1
spafxer is offline   Reply With Quote
Old 07-05-2014, 12:51 PM   #5
maloryII
more north, more wet
 
maloryII's Avatar
 
Joined: Mar 2008
Location: Tacoma, WA
Oddometer: 3,687
Sounds like what happened when my FP died. Easy fix, just order a new one and plug and play.
__________________
2006 KTM 950 Adventure

"The pen & sword, in accord."
"It's never over in a Rover."
maloryII is offline   Reply With Quote
Old 07-05-2014, 03:10 PM   #6
hotrdd OP
Adventurer
 
Joined: Jan 2014
Location: Calgary, Alberta
Oddometer: 74
so its normal for it to just start working again?

is it safe to ride it while I Wai for a fuel pump ⛽ or will I only get a few more miles out of it?

would you order two fuel pumps right away? Are they really a consumable part?
hotrdd is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:08 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014