ADVrider

Go Back   ADVrider > Bikes > Old's Cool > Airheads
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 06-29-2009, 08:19 PM   #1
baldwithglasses OP
Godspeed, Robert
 
baldwithglasses's Avatar
 
Joined: Jul 2007
Location: East Atlanta Village, Atlanta, Georgia
Oddometer: 795
#Airhead: I grounded out and lost both headlight relay and starter relay

Bought an Omega charging system from Nathan at Boxerworks and while installing it, grounded out my custom ground strap (from previous diode board arrangement) between bike ground and the positive terminal off the starter. Sparks, blue smoke, and the bike don't work no more.

Sadness.

Spent past week and weekend chasing down replacement parts and wrecking them, and no, the relays you might get at NAPA don't work. DAHIMK. Bike's out in Palmetto GA, across from Serenbe, so it's real pretty and peaceful and there's scant cell coverage and scant wifi out that way.
baldwithglasses is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:00 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014