ADVrider

Go Back   ADVrider > Bikes > GSpot > GS Boxers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 08-19-2009, 08:08 PM   #1
Tantalum Kid OP
n00b
 
Joined: Aug 2009
Oddometer: 5
Fuel Pump Driver Failed on an 08 R1200GS

250 km into a weekend trip my bike wouldn't run. It would start, rev-out or idle for about 2 seconds, but wouldn't run. This happenned for about 30 starting attempts. After that all it would do is crank over, but not start. There were no warning or fault codes on the dash. BTW it was raining off-and-on all day.

Thanks to BMW roadside assistance the bike was trucked to a dealer (about a 200 km tow). The dealer diagnosed the situation as a faulty fuel pump electronic controller - aka fuel pump driver - and a replacement is currently on order (2 week delivery).

A little research revealed these controllers became wet due to a flawed o-ring seal. However, this situation was reported in 2005 and one might assume that this had been fixed for the 08 models.

1. Can anyone report this happenning to other 08-R1200GSs?
2. Is it possible to carry out a road-side replacement of the fuel pump electronic controller?

Jim
___________________
'08 R1200GS
'08 F650GS (twin)
Tantalum Kid is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 09:19 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014