ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-12-2010, 07:02 PM   #10
kalsop
...........
 
kalsop's Avatar
 
Joined: Oct 2006
Location: NOVA
Oddometer: 80
Quote:
Originally Posted by eakins View Post
start by cleaning it with pine sol soak (google for hondo's thread)

you might have sticky/gummed throttle cables or throttle tube.
I did the jesse mod on my previous Dr and transferred everything back to stock but the slide piston with the extra hole drilled in it. The throttle seemed to be a bit to abrupt on deceleration. The throttle is very snappy as for as the thottle body spring back is conserned, it just seems to be a little long on deceleration. this bike only had 495miles put on it from oct 08 unil now so no telling what might have a little gum still holding on in the carb. Maybe it will subside once it has some real miles put on it.
kalsop is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:19 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014