ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 05-22-2012, 06:42 PM   #10
CanadianX
Oh!? That is deep.
 
CanadianX's Avatar
 
Joined: Dec 2010
Location: Ontario
Oddometer: 1,221
I've knocked out the first 1000 km on mine without issues. Did notice some coolant leaking from the hose going into the overflow tank but that has since stopped. Bikes goes in for it's first break in servicing tomorrow. No mods to exhaust or air intake yet, likely will only do the exhaust...maybe the air filter. There does seem to be a spot in the throttle where the bike catches and stalls on occasion. I've only noticed it when you are giving light blips to the throttle with the clutch in, like when you are feathering the clutch and blipping the gas when negotiating technical terrain. The solution, more aggressive twists. No stalls when simply sitting at idle or anything. Gobs of power and torque. My buddies 2011 with an FMF does have noticeably crisper throttle response down low, something to consider.

Mods for far:
- Pivot Pegs
- Rox Risers
- Flatland Skid Plate
- Touring screen
- ACV Grab on Grip Covers
- Double Take folding mirrors
- Put the rear passenger grab handles on and deleted the rear passenger pegs




Some vid of me and my friend out playing. (Skip the first 2:30) I almost clear the creak at 4:20
http://www.youtube.com/watch?v=-efQhjfwURg
CanadianX is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:38 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014