ADVrider

Go Back   ADVrider > Riding > Regional forums > Australia > OZ Vendors
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-09-2012, 04:52 AM   #61
Aquatic OP
Beastly Adventurer
 
Aquatic's Avatar
 
Joined: Dec 2008
Location: Buddina, Sunny Coast, Australia
Oddometer: 1,317
Thumb A customer's setup - F800GS ready for the APC rally

Thanks Werner



Aquatic is online now   Reply With Quote
Old 07-12-2012, 04:07 AM   #62
Moptop
Adventurer
 
Moptop's Avatar
 
Joined: Apr 2011
Location: South Coast,NSW, Australia
Oddometer: 68
Great mount Craig. Only thing to watch is the little screw. It vibrated loose and noticed it just before I lost it. A bit of loctite should fix that.
Very happy customer.
Moptop is offline   Reply With Quote
Old 07-12-2012, 04:39 AM   #63
Aquatic OP
Beastly Adventurer
 
Aquatic's Avatar
 
Joined: Dec 2008
Location: Buddina, Sunny Coast, Australia
Oddometer: 1,317
Quote:
Originally Posted by Moptop View Post
Great mount Craig. Only thing to watch is the little screw. It vibrated loose and noticed it just before I lost it. A bit of loctite should fix that.
Very happy customer.
Thanks W

You are the second person to have this happen, though a low percentage it is a problem I will endevour to solve. There seems to be inconsistancy with the screws WRT sizing. Frustrating!

The spring is strong enough that your radio should not fall out under normal circumstances. The screw is a locking mechanism mainly to prevent theft when you pop into a pub or go pay the fuel bill.

Be careful with loctite, as you might lock it up permanently.
.
Thank you for the feed back
Aquatic is online now   Reply With Quote
Old 07-12-2012, 05:48 AM   #64
richo360
Studly Adventurer
 
Joined: Sep 2011
Location: Melb S/S/E
Oddometer: 715
Thanks for posting this and you PM info Aquatic....... Sort of out of funds and time to get this sorted for APC but will definitely be back to you in a few months.
__________________
700RR
richo360 is offline   Reply With Quote
Old 07-13-2012, 01:20 AM   #65
nry
.
 
nry's Avatar
 
Joined: Jan 2008
Location: Sydney
Oddometer: 1,197
Hi craig,
Longshot but, do you make anything for the icom 41W ? Or will this one work .... He asked knowing it won't.
Cheers.
nry is offline   Reply With Quote
Old 07-14-2012, 12:02 AM   #66
Aquatic OP
Beastly Adventurer
 
Aquatic's Avatar
 
Joined: Dec 2008
Location: Buddina, Sunny Coast, Australia
Oddometer: 1,317
Quote:
Originally Posted by nry View Post
Hi craig,
Longshot but, do you make anything for the icom 41W ? Or will this one work .... He asked knowing it won't.
Cheers.
As it stands, no!
But......
do you have a MB-93 belt clip?
If yes take some photos and sizes of the pip on the radio and I will let you know if it can work.
I can honestly say I don't think the mount will work as is. But maybe some minor mods and could have a Icom model.

I will see if I can find one to look at in the local area.

Watch this space.
Aquatic is online now   Reply With Quote
Old 07-14-2012, 12:08 AM   #67
Aquatic OP
Beastly Adventurer
 
Aquatic's Avatar
 
Joined: Dec 2008
Location: Buddina, Sunny Coast, Australia
Oddometer: 1,317
Pissed Some bad postage news

So....
I have had my first 2 non deliveries with Aus post regular mail

Unfortunately I will only be using express post from now on. So no more $10 regular shipping, only $12 express post shipping.

Sorry guys, circumstances beyond my control.
Aquatic is online now   Reply With Quote
Old 07-15-2012, 04:44 PM   #68
nry
.
 
nry's Avatar
 
Joined: Jan 2008
Location: Sydney
Oddometer: 1,197
Quote:
Originally Posted by Aquatic View Post
As it stands, no!
But......
do you have a MB-93 belt clip?
If yes take some photos and sizes of the pip on the radio and I will let you know if it can work.
I can honestly say I don't think the mount will work as is. But maybe some minor mods and could have a Icom model.

I will see if I can find one to look at in the local area.

Watch this space.
Cheers, my sure what kind of clip yet as it hasn't arrived but will let you know when I know.
nry is offline   Reply With Quote
Old 07-15-2012, 04:47 PM   #69
Aquatic OP
Beastly Adventurer
 
Aquatic's Avatar
 
Joined: Dec 2008
Location: Buddina, Sunny Coast, Australia
Oddometer: 1,317
Quote:
Originally Posted by nry View Post
Cheers, my sure what kind of clip yet as it hasn't arrived but will let you know when I know.

Aquatic is online now   Reply With Quote
Old 07-26-2012, 08:16 PM   #70
SirJono_777
Adventurer
 
SirJono_777's Avatar
 
Joined: Apr 2008
Location: South Coast NSW, Australia
Oddometer: 51
Does the 12v charger stay attached by itself? It looks like it would fall off after a few bumps? I ride primarily offroad/firetrails so I think I will need to zip tie it on if I get one of these 12v units.

Quote:
Originally Posted by BurraBob View Post
Yes Thank you Craig,
I have just been out in the shed fitting and taking Pics. Mount is excellent




SirJono_777 is offline   Reply With Quote
Old 08-14-2012, 10:47 PM   #71
griffo1962
Beastly Adventurer
 
griffo1962's Avatar
 
Joined: Oct 2006
Location: Carrara, Qld, Australia
Oddometer: 1,348
Pics of mine

Old one on the KLR



New one on the KLX



Both




Craig does beautiful work. Even my first one which is a "second" is a work of art.....
griffo1962 is online now   Reply With Quote
Old 08-15-2012, 04:09 AM   #72
Aquatic OP
Beastly Adventurer
 
Aquatic's Avatar
 
Joined: Dec 2008
Location: Buddina, Sunny Coast, Australia
Oddometer: 1,317
Thanks for the photos and kind words Griffo.
Looks good!


I'm hoping to get some feedback from the APC riders.
It would be nice to know how it held up in some extreme riding conditions.
Aquatic is online now   Reply With Quote
Old 08-16-2012, 08:35 PM   #73
Moptop
Adventurer
 
Moptop's Avatar
 
Joined: Apr 2011
Location: South Coast,NSW, Australia
Oddometer: 68
I'm hoping to get some feedback from the APC riders.
It would be nice to know how it held up in some extreme riding conditions.[/QUOTE]

Bought 2 for myself and a mate to mount our radios for the APC rally. I'm happy to give this product a 5 Star rating. I had an off and the radio spun in the cradle but stayed on. My mate had a big off and radio and brackets stayed in place. Same cant be said for his handlebar
Moptop is offline   Reply With Quote
Old 08-17-2012, 04:47 AM   #74
Aquatic OP
Beastly Adventurer
 
Aquatic's Avatar
 
Joined: Dec 2008
Location: Buddina, Sunny Coast, Australia
Oddometer: 1,317
That looks expensive!

Thanks for crash testing the mount Moptop.
Any damage to the mount when the radio did a 360?

Quote:
Originally Posted by Moptop View Post
I'm hoping to get some feedback from the APC riders.
It would be nice to know how it held up in some extreme riding conditions.
Bought 2 for myself and a mate to mount our radios for the APC rally. I'm happy to give this product a 5 Star rating. I had an off and the radio spun in the cradle but stayed on. My mate had a big off and radio and brackets stayed in place. Same cant be said for his handlebar
[/QUOTE]
Aquatic is online now   Reply With Quote
Old 08-17-2012, 05:49 PM   #75
Moptop
Adventurer
 
Moptop's Avatar
 
Joined: Apr 2011
Location: South Coast,NSW, Australia
Oddometer: 68
[QUOTE=Aquatic;19380379]That looks expensive!

Thanks for crash testing the mount Moptop.
Any damage to the mount when the radio did a 360?

No. That is why I think the mount is great. The impact allowed the radio to spin in the mount without any damage to the mount or the radio. Big thumps up from me. After the off I just turned the radio, till it clicked back I'm place with the side knobs. I did not end up using loctite on the screw as per you recommendation, I just tighten it a bit more after my initial ride when it vibrated loose, and had no problems at all. I abviously did not have the screw tight enough the first time.
Moptop is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 04:04 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014