ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-09-2012, 11:54 AM   #1
BOB RAMSAY OP
Not in the Clique -
 
BOB RAMSAY's Avatar
 
Joined: Jul 2011
Location: Granville, Ohio
Oddometer: 292
Rear brake - way too weak (950)

My rear brake is about 5% effective - actually, more like 0%, as I cannot stop the bike, even under 10mph.

A little history:

2006 950 Adventure
OEM pads/rotor, 24k miles (all road).
Pads 6mm thick.
Had a light oil contamination on pads/rotor last week (don't ask. . . ).
Pulled, cleaned and sanded pads and sanded rotor today. Nada.
Fluid changed summer 2010. Free play is good.
There is some pressure at pedal, no pressure being applied to the rotor.

Can the wheel cylinder 'blow by' the seals when the brake is applied?



Any help would be appreciated. Thx -
__________________
I'll take Heaven for the climate - Hell for the company.

BOB RAMSAY screwed with this post 10-25-2012 at 06:12 AM
BOB RAMSAY is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:23 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014