ADVrider

Go Back   ADVrider > Riding > Layin' down tracks
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-23-2012, 08:28 AM   #1
Three Dawg OP
Studly Adventurer
 
Three Dawg's Avatar
 
Joined: Apr 2009
Location: The Highlands of Scotland
Oddometer: 502
Garmin SP 2610 earphone connection

I've recently fitted a Garmin 2610 Street Pilot to my GS. Don't laugh, I like it, and it was very cheap! Can't read the notes in the top of my tankbag any more so I just bang the route into the GPS and away I go- don't need it to do any thinking for me...

Anyway, I also bought an earpiece for it which has a 2.5mm stereo jack into a single helmet speaker, plugged it in and unfortunately it doesn't work. Tried it with the (stereo) earphones off my phone and it works fine, though only through one ear.

Is the Garmin plug a strange type? I tried pulling the plug out of the socket out slightly but no go.

Three Dawg screwed with this post 10-23-2012 at 09:39 AM
Three Dawg is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:58 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014