ADVrider

Go Back   ADVrider > Bikes > Battle scooters
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-28-2012, 04:44 AM   #1
ride4321 OP
Beastly Adventurer
 
ride4321's Avatar
 
Joined: Dec 2009
Location: Binghamton, NY
Oddometer: 1,427
84 Honda Elite 125 questions...

I posted on another thread here a few days ago about this Elite I picked up for $100. Thought I'd start a new thread since I'm gonna have a lot of questions and maybe I can get some answers here.



running!

http://youtu.be/8VbcPVuXns4

So I've got it running which is good. Don't have much info on this bike but did get the service manual online. I don't have a key but the switch has be "modified" and I can turn it with a pair of pliers now.

First question. It's on the center stand running but the rear wheel isn't turning, not even when I give it more throttle. I thought it should engage with throttle input. Is it possible the brake switch is sticking? I haven't messed with that yet.
__________________

Don't you know there ain't no devil, it's just God when he's drunk.
Tom Waits
ride4321 is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:45 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014