ADVrider

Go Back   ADVrider > Bikes > Orange Crush > Crazy-Awesome almost Dakar racers (<1000cc)
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-12-2012, 09:45 PM   #1
lenny6753 OP
Adventurer
 
Joined: Apr 2010
Oddometer: 88
Problems finding parts?

Ok, here goes. Long story from several other threads but the short of it is I think my ignition switch/barrel is going bad. I can't say for sure because I cannot pry it open to try and service it(I already have two holes in my hand from trying). I decided to order the part which I posted in another thread if anyone knew where to obtain it but no luck so far.

I contact several KTM dealers and online parts stores in an attempt to purchase the insert ignition lock which is the bottom portion of the ignition barrel where the wires enter. No luck. Everyone tells me they can order them from KTM Austria but the part will not ship until December 7 at earliest.The dealers are unable to locate this part any where in the U.S. I have to wait at least seven weeks before the part is even available and that assumes it ships on time and who knows how long it will take to arrive.

I understand KTM is a smallish company but it seems unacceptable that this part is unavailable here(U.S.) and that there are none in stock at KTM Austria. So how exactly does KTM expect their customers to repair their bikes? Or do they even care? Don't misunderstand, I love my 990, but this is ridiculous. Has anyone else had problems finding parts or having to wait forever to get them? Am I asking to much? I apologize for the rant but am frustrated with KTM.
lenny6753 is offline   Reply With Quote
Old 10-13-2012, 10:55 AM   #2
spencergt66
Studly Adventurer
 
Joined: Jun 2011
Location: Seattle WA
Oddometer: 736
Call chip at munn racing if he can't get it there really aren't any to be had
spencergt66 is offline   Reply With Quote
Old 10-27-2012, 03:44 PM   #3
pebble35
Beastly Adventurer
 
pebble35's Avatar
 
Joined: Dec 2007
Location: Jersey, Channel Islands
Oddometer: 1,418
Quote:
Originally Posted by lenny6753 View Post
Ok, here goes. Long story from several other threads but the short of it is I think my ignition switch/barrel is going bad. I can't say for sure because I cannot pry it open to try and service it(I already have two holes in my hand from trying). I decided to order the part which I posted in another thread if anyone knew where to obtain it but no luck so far.

I contact several KTM dealers and online parts stores in an attempt to purchase the insert ignition lock which is the bottom portion of the ignition barrel where the wires enter. No luck. Everyone tells me they can order them from KTM Austria but the part will not ship until December 7 at earliest.The dealers are unable to locate this part any where in the U.S. I have to wait at least seven weeks before the part is even available and that assumes it ships on time and who knows how long it will take to arrive.

I understand KTM is a smallish company but it seems unacceptable that this part is unavailable here(U.S.) and that there are none in stock at KTM Austria. So how exactly does KTM expect their customers to repair their bikes? Or do they even care? Don't misunderstand, I love my 990, but this is ridiculous. Has anyone else had problems finding parts or having to wait forever to get them? Am I asking to much? I apologize for the rant but am frustrated with KTM.
What year/model ? PM me and I will see if we can help.
__________________
Proud to be supporting Pyndon
www.lyndonposkittracing.com

www.bikersjersey.com for all your KTM parts
A 2,400 KM ride around Egypt by Scooter - ride report here
pebble35 is offline   Reply With Quote
Old 10-28-2012, 03:14 PM   #4
gefr
Life is a trip
 
gefr's Avatar
 
Joined: Nov 2005
Location: East Med, Greece
Oddometer: 3,791
If you want to go international

In Germany:

http://www.ktm-versand.de/index.php/language/en

or nationally:

http://www.ktmcyclehutt.com/

http://www.munnracing.com/index.html

and on ebay:

http://www.ebay.com/itm/IGNITION-SWI...620e86&vxp=mtr

Good luck
gefr is offline   Reply With Quote
Old 10-31-2012, 06:42 PM   #5
lenny6753 OP
Adventurer
 
Joined: Apr 2010
Oddometer: 88
Thanks to everyone for your help. I ordered the part from cheapcyclepart.com and it was on back order until December. I was notified today the part has shipped so I should see it in about a week.

I certainly appreciate everyone's help. Thanks CJ for letting me bend your ear. I am still unsure this part(insert ignition lock) is what was causing the problem and I was unable to recreate the problem after it initially occurred. After checking all the connections/wires/relays/circuits I can get to without removing the entire wiring harness/loom this was the only part I could not check. Hopefully this solves the issue.
lenny6753 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:07 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014