ADVrider

Go Back   ADVrider > Bikes > Old's Cool > Airheads
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-16-2012, 06:19 PM   #17
disston
ShadeTreeExpert
 
disston's Avatar
 
Joined: Mar 2011
Location: Silver Spring, Md
Oddometer: 7,340
It looks like the condenser was compromised for what ever reason. No condenser, no spark. And changing the points was probably a good idea. It is really hard to gap a used set of points, sometimes impossible.

It is also considered an improvement of the system to add a Booster because the points will last for a long long time with a Booster and the condenser is not used with a Booster. If there should be a problem the Booster can be by passed and the ignition returned to OEM in a few minutes (unless like me you have bar backs which adds a bunch of time to the procedure, I know, recently had to do this in a shopping mall parking lot)

There are other electronic ignition systems that can be used on Airheads. Some have other added advantages but the Booster is the one I prefer (I have had a Dyna III). But I will be running the OEM system for awhile, till I get a new job.
__________________
.
Never memorize something you can look up.
---Albert Einstein

Pay your debt, privatejohn.http://www.advrider.com/forums/showthread.php?t=949341
disston is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 02:58 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014