ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-22-2012, 08:21 AM   #751
DrMoto
Adventurer
 
Joined: Aug 2011
Location: California, USA
Oddometer: 26
Seat Concepts->KLR250

Received my Seat Concepts upgrade kit for KLR250 this week (promptly).
Initially I was kind of wishing that I'd simply shipped them my seat pan and paid the extra $20 for installation. But as a long-term DIY-er, I took my time and got it installed without wrinkles. See photo.

Haven't done a ride on it yet but looks like a nice upgrade. New foam is a bit wider. And newer.
__________________
'00 KLR250
'07 FJR1300
DrMoto is offline   Reply With Quote
Old 11-22-2012, 12:24 PM   #752
bigfishs
Adventurer
 
Joined: Oct 2007
Location: albany, NY
Oddometer: 46
Very nice, what did that cost?
bigfishs is offline   Reply With Quote
Old 11-22-2012, 12:33 PM   #753
bigfishs
Adventurer
 
Joined: Oct 2007
Location: albany, NY
Oddometer: 46
Picked up a 94 KLR from my buddy, 6000 miles. I actually sold him the bike after having it for 1 summer, but thats another story.

Anyway,

Bike has fresh gas, new plug (havent checked gap on it or valve clearance yet) and a new fuel filter. It does this weird thing where it has no power after being started cold. If you let the clutch out in gear it just dies unless you give it a running start. It also seemed to die when I put the clutch in, the revs would drop and it would die despite me revving it. I just tried to repeat the problem after sitting for 4 hrs but it started right up and ran fine.

I guess I'll try to repeat the problem after it sits overnight. Anyone had a similar problem?



Photobucket
bigfishs is offline   Reply With Quote
Old 11-23-2012, 11:10 PM   #754
gasolinetom
Mechanic
 
gasolinetom's Avatar
 
Joined: Nov 2012
Location: Texas
Oddometer: 21
KLR 250 exhaust / carb

i did the 22 cent mod, added two washers to the needle, running 38 and 118 jets, fuel mixture screw set 2 and a half turns out, and baffle removed. no airbox mods. runs great, coolant gauge straight up and down. great throttle response and power with no flat spots. my slow jet is stripped so i think i have to drill it out to remove it, i want to move the jets up to 38-40 and somewhere in the upper 120s for the main jet. im running without a baffle, no problems so far. oh, the bike was backed into by a car while on the sidestand and it broke off the sidestand tab, snapped it right off the frame, im having trouble rewelding it to the frame at the correct angle, are there any aftermarket side stands that bolt on, or even clamp on to the swingarm that i could use, getting a little tired of leaning against trees.
gasolinetom is offline   Reply With Quote
Old 11-23-2012, 11:17 PM   #755
Hannda
Short, fat, bearded, slow
 
Hannda's Avatar
 
Joined: Apr 2005
Location: Studiously avoiding the cookie jar
Oddometer: 26,652
Try going here . . .

http://www.advrider.com/forums/showthread.php?t=340288
Hannda is offline   Reply With Quote
Old 11-23-2012, 11:19 PM   #756
gasolinetom
Mechanic
 
gasolinetom's Avatar
 
Joined: Nov 2012
Location: Texas
Oddometer: 21
ok, so i bought this bike for $800 in march 2012 with nearly 3000 miles on the clock. it was white, had a cold starting issue and old cracked up tires
on account of the tires, i had it trailered back to my house so i could give it a fine toothed comb inspection. the tires were cracking, but still had a couple miles left on them, seeing as i just go around town mostly, i thought this was ok.

after driving it around town a couple weeks, i decided that the carb would have to be cleaned again.
upon inspection of the carb, i found rust, and that the airbox to carb manifold would have to be replaced, so i ordered the part and cleaned the carb really well. drilled the plug and turned the screw two turns out.
i added a mirror to the left side as this bike came to me with neither mirrors nor blinkers.
gasolinetom is offline   Reply With Quote
Old 11-23-2012, 11:36 PM   #757
gasolinetom
Mechanic
 
gasolinetom's Avatar
 
Joined: Nov 2012
Location: Texas
Oddometer: 21
one day i decided to take it on the highway to my school that was about 5 miles down the highway, that is when the problems started. it got up on the highway just fine, a little more vibration than i was used to as i had knobby tires. also, i had to flip to the reserve tank as soon as i got there, thinking i would have to fill up on the way home.

After class it was a PITA to start and it kept dying on me so i took the backroads back home as they were slower, but it adds a mile to my trip. i must have had to pull over and kick it (about 20 times to start) every quarter mile. what i failed to mention earlier is that the tank had once had rust in it and the previous owner said he power washed it out. i thought that this would account for the rust i had found in the carb when i had cleaned it.
when i got home i removed the tank, the carb, airfilter (whick was rotten). the tank was almost empty, so i drained out the dirtiest fuel ive ever seen. full of rust and crap. i pulled the petcock to find the screens on the main drain were clogged with rust and the reserve line had no filter tower, and was also clogged with rust. i didnt even try to mess with it, i had a spare petcock form another project that fit, so i tossed the old petcock in the trash. i went to the store and got an airfilter and a kreme kit , and started to kreme the tank.
tank kremed, carb recleaned, new airfilter. decided now as good a time as any so i changed the oil and filter while i was at it. threw it all back together. ran great.
about 1000 miles later it was becoming hard to start cold so i did a valve adjustment. now it kicks on the first try.
then i put some nice shinko 50/50 tires on it, and cleaned and lubed the chain.
i removed all the plastics minus the tail section and painted them od green, looks sharp. and ditched the crap tool bag for a small military box, plastic with a waterproof seal, it was a throwaway from when my old army unit was moving to colorado, glad i saved it. i also added a nice steel license plate mount and used the plate bolts that have the little leds in there so my rear plate will be illuminated.
gasolinetom is offline   Reply With Quote
Old 11-23-2012, 11:48 PM   #758
gasolinetom
Mechanic
 
gasolinetom's Avatar
 
Joined: Nov 2012
Location: Texas
Oddometer: 21
i ve taken my girlfriend on the back of it to dallas and back a couple times, she loves it. made her assist me in doing another oil change and a radiator flush.

there was a clicking noise from the front tire. i tightened all the spokes as they were all loose. no noise.

one day when i was down in dallas it started making a clicking grinding noise it the front and the speedometer was jumping around so i pulled over and removed the inner cable of the speedo. no noise. it had just backed out a little from the gauge. i fixed and lubed it when i got home. no noise, happy speedo.

one day i parked it on the street near the bars and had a few drinks,,,, the next day when i returned to the bike, or rather where i had parked the bike, it was gone. i found the kickstand on the ground in the middle of the road, the mounting tab still attached to it. the bike was leaned up against a light pole about half a block from where i had parked it. and half the gas was missing from the tank. im guessing some one backed into it real slow, as the wheels were still in good shape, and that snapped off the kickstand. then maybe someone saw it laying in the middle of the street, where it leaked half the gas out, and righted it, and put it on the light pole. now i have to lean it against trees and the sides of buildings. if anyone knows of a good clamp-on side stand, please let me know. PM me PLEASE!!
i turned my fuel mixture screw to 2 and a half turns out, from bottom, and added two #4 washers (.22 cent mod) to the needle, also removed the baffle but left the spark arrestor in place. rides great, sounds awesome. the coolant needle stays straight up and down. right in the middle of the gauge, it runns a little cooler when im on the highway, but it never gets any hotter.
gasolinetom is offline   Reply With Quote
Old 11-23-2012, 11:50 PM   #759
gasolinetom
Mechanic
 
gasolinetom's Avatar
 
Joined: Nov 2012
Location: Texas
Oddometer: 21
i didnt balance the tires when i put new ones on, kinda wish i did. is slime any good? i use in on bicycles all the time, but i dont know how it would pan out of the klr. anyone use balance beads?
gasolinetom is offline   Reply With Quote
Old 11-23-2012, 11:52 PM   #760
gasolinetom
Mechanic
 
gasolinetom's Avatar
 
Joined: Nov 2012
Location: Texas
Oddometer: 21
when the bike was white, it had an awful blue seat, so i picked up some marine grade black seat vinyl and re covered the seat, only took two hours, but it looks professional.
gasolinetom is offline   Reply With Quote
Old 11-24-2012, 08:17 AM   #761
RebelYell
Gnarly Adventurer
 
Joined: Jan 2012
Location: somerset nj
Oddometer: 476
Any pics comrade?
RebelYell is offline   Reply With Quote
Old 11-24-2012, 09:55 AM   #762
XDragRacer
Beastly Adventurer
 
Joined: Mar 2009
Oddometer: 2,721
Quote:
Originally Posted by gasolinetom View Post
when the bike was white, it had an awful blue seat, so i picked up some marine grade black seat vinyl and re covered the seat, only took two hours, but it looks professional.
Just wonderin'; why not post on the thread identified by Hannda (http://www.advrider.com/forums/showthread.php?t=340288)?
XDragRacer is offline   Reply With Quote
Old 11-24-2012, 02:15 PM   #763
XDragRacer
Beastly Adventurer
 
Joined: Mar 2009
Oddometer: 2,721
Quote:
Originally Posted by gasolinetom View Post
good question. why would i make a page about MY klr250 mechanical problems and MY klr250 choices when i could post it in a sea of other comments on SOMEONE ELSE's page. because this one is mine. :)
As Steve Martin might say, "Well EXCUUUUUUUUUUSE ME!"



--------------------------------

I reckon EVERY post might be the first of a new thread, avoiding any "sea of other comments."

And, unless you started it, EVERY thread is "SOMEONE ELSE's."

This thread, certainly, is YOURS!

XDragRacer screwed with this post 11-24-2012 at 05:01 PM
XDragRacer is offline   Reply With Quote
Old 11-24-2012, 04:03 PM   #764
gasolinetom
Mechanic
 
gasolinetom's Avatar
 
Joined: Nov 2012
Location: Texas
Oddometer: 21
hahaha,
gasolinetom is offline   Reply With Quote
Old 11-24-2012, 04:43 PM   #765
8gv
Beastly Adventurer
 
Joined: Nov 2009
Location: North central CT
Oddometer: 2,228
It's actually "EXCUUUUUUUUUUSE ME!"
8gv is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:26 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014