ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-02-2012, 03:36 PM   #1
Carter Pewterschmidt OP
Studly Adventurer
 
Carter Pewterschmidt's Avatar
 
Joined: Nov 2010
Location: Milwaukee
Oddometer: 966
Anyone run pod filters on an XL600R?

Just wondering what spec filters you've used, like angled or not, and what fitment issues if any. Pics if you got em. Thanks!
Carter Pewterschmidt is offline   Reply With Quote
Old 12-06-2012, 03:59 PM   #2
High Country Herb
Adventure Connoiseur
 
High Country Herb's Avatar
 
Joined: Apr 2011
Location: Western Sierras
Oddometer: 6,620
I haven't even opened the airbox in about 5 years, so I guess it works. I'm so bad about maintenance on my Hondas. If it isn't broke, I don't mess with it, and well....it doesn't break. I should get in there and clean it to free up some ponies.

I think it is a Uni, and it came with the bike when I bought it about 10 years ago.
High Country Herb is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 01:30 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014