ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-08-2013, 03:03 PM   #1
Somewhere Far Beyond OP
Gnarly Adventurer
 
Somewhere Far Beyond's Avatar
 
Joined: Nov 2012
Location: The Great Northwet
Oddometer: 121
Eek My 950 left me STRANDED?

So I went to start my 06 950 S today. Started up just fine. Went in gear just fine (I have a Rekluse clutch), and then when I put a bit of throttle on.... she made a bit of a kalack-ing type sound and died. Trying to restart.... the starter just spins, no engagement, although on some attempts for a split second it seems like it's trying to engage.

So I had to have it towed...
Thank goodness for the AMA! Free towing!

Before I rip into it... what does it sound like I'm up against? What possibilities are there on this machine that I could be experiencing?

Also, I'm guessing this is a good time to do the water pump? The bike is approaching 38k and I haven't had it long... no idea when/if the water pump has been done. And should I do the starter as preventative maintenance? Is it a common failure. I've been thinking of doing a fuel pump upgrade as well.... and a side stand relocator kit.



Any help is greatly appreciated.
__________________
2003 KTM 640 Adventure
2004 KTM 950 Adventure
And I don't fear that dusty godforsaken path
Somewhere far beyond...
Somewhere Far Beyond is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 07:28 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014