ADVrider

Go Back   ADVrider > Bikes > Old's Cool > Airheads
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-16-2013, 05:42 AM   #30
ignatz72
call me iggy
 
ignatz72's Avatar
 
Joined: Aug 2010
Location: Mid-South, M-town
Oddometer: 626
Quote:
Originally Posted by disston View Post
It's starting to look like the only suspect. I've never had this problem. Do you think it is possible to take the relay apart and clean/fix it? I have cleaned the contacts in other relays but the turn signal relay on Airheads are not a normal type, are they?
A /6 relay is a three/four pronged affair in the bucket, right? If so, I'd imagine taking it apart to inspect should be easy enough.

However, I just replaced my dead starter relay (on a GS) which I opened up to inspect. It looked assembly line new inside, yet it was dead. So don't count on internal appearance as a factor in whether it needs replacing.

I would recommend stock parts when troubleshooting electrical issues, since getting a relay substitute that isn't 100% right could lead you astray if it still doesn't work! But SHEESH, that relay is pricey!
__________________
Current: 93 R100GS, 03 XR650R
Prior: 73 CB350, 77 R100/7, 83 R100RT, 04 XR650L
I love every motorcycle I've owned and even some that I haven't.

ignatz72 screwed with this post 01-16-2013 at 05:48 AM
ignatz72 is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:34 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014