ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-13-2013, 02:20 PM   #1
wowsers OP
F8 & b there
 
wowsers's Avatar
 
Joined: Feb 2012
Location: New Brunswick, Canada
Oddometer: 29
KLR650 Triple tree bearing

I own a 2008 KLR650 and the lower triple tree bearing was toast so I ordered a set from ALLBALLS racing. I noticed that the bottom seal does not fit flush against the bottom of the triple tree like the oem seal did, I installed the bearing and seal today anyway and there is a 1/8 of an inch gap between the bottom of the seal to the triple tree. Is this normal or did I get a bad seal?

Any of you guys experienced this situation with these aftermarket seals?
__________________
F8 & b there!
You know what it means don't you?
wowsers is offline   Reply With Quote
Old 01-13-2013, 05:31 PM   #2
redneckdan
Hold my beer & watch this
 
Joined: Oct 2008
Location: Somewhere on da Iron Range.
Oddometer: 576
Had the same problem with my wife's klr 250. I ordered a set of factory seals. When you get that far, you'll notice the top seal in the all balls kit ain't even friggin close to working properly. I was not impressed.
__________________
Fly Rods, Kids and a KLR
redneckdan is offline   Reply With Quote
Old 01-16-2013, 04:26 PM   #3
wowsers OP
F8 & b there
 
wowsers's Avatar
 
Joined: Feb 2012
Location: New Brunswick, Canada
Oddometer: 29
After sending a photo of the bearing and seal assembly to ALLBALLS racing, they said that this was the way that their seal was intended to be installed so I went ahead and put all that together and everything is fine.
__________________
F8 & b there!
You know what it means don't you?
wowsers is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:52 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014