ADVrider

Go Back   ADVrider > Bikes > GSpot > Parallel Universe
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-16-2013, 07:19 PM   #11
jttele
Gnarly Adventurer
 
jttele's Avatar
 
Joined: Feb 2005
Location: Alexander, NC
Oddometer: 197
Quote:
Originally Posted by Indy Unlimited View Post
Most likely needle bearings are shot.
I am recommending moly paste for lubrication these days.
Post pics and PM me for any parts you need for free.

I have seen a few shafts over heat treated and have brittle flaking failure that can damage the needle bearings.
Since you ride 2 up loaded a lot and mostly off road that is the toughest loading on the shock mounts.
Well it's probably overkill, but I got an extra needle bearing to put in the top shock mount to share the load so now it has three bearings instead of the two in the Indy kit. The two outside bearings stick out about 2mm, but the running surface of the needles is still well inside the bore of the shock they're inserted into. This is on a stock shock by the way. The bearings might not even be the problem for Snowy, but I guess we'll see soon enough.
__________________
Jttele
jttele is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 04:36 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014