ADVrider

Go Back   ADVrider > Riding > Trip Planning > Americas
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-29-2013, 03:43 AM   #16
Fast103 OP
Adventurer
 
Joined: May 2012
Location: toronto, Canada
Oddometer: 44
Quote:
Originally Posted by Lone Rider View Post
It's good to hear your trip is going well.

At some time in the future, you may feel better about doing the basic services to the bike yourself.
The less dependent a person is on others, the stronger he becomes.

Were you offered coffee while waiting for the dealership to perform these services for you?

Always, best and safe travels to you.
There was a warranty problem to be fixed! It made sense while the bike was there for them to change my pads....common sense101. The rest was done as they saw fit. I am quite capable of doing basic stuff myself...having raced cars for 6 years.
I really do not need your sage advice...thank you!
BTW I read my documents as apparently you should have done while entering MEXICO. PLEASE...after this clutter someone elses's threads.

Fast103 screwed with this post 01-29-2013 at 04:08 AM
Fast103 is offline   Reply With Quote
Old 01-29-2013, 03:29 PM   #17
Lone Rider
Registered User
 
Joined: Jan 2002
Location: out and about
Oddometer: 25,130
Quote:
Originally Posted by Fast103 View Post
....common sense101. The rest was done as they saw fit...
What was the warranty issue?
Lone Rider is offline   Reply With Quote
Old 02-01-2013, 11:08 AM   #18
Fast103 OP
Adventurer
 
Joined: May 2012
Location: toronto, Canada
Oddometer: 44
Post

Quote:
Originally Posted by Lone Rider View Post
What was the warranty issue?
Lone Rider, please read my original post. The one you originally started harassing me about!
Fast103 is offline   Reply With Quote
Old 02-01-2013, 02:53 PM   #19
Lone Rider
Registered User
 
Joined: Jan 2002
Location: out and about
Oddometer: 25,130
Quote:
Originally Posted by Fast103 View Post
Lone Rider, please read my original post. The one you originally started harassing me about!
This sounds unusual.
Where was the oil leaking from on your bike?
What service did they perform to fix the leak?
Was a new gasket needed?

Those are pretty much leak-proof motors, in my experience.
Lone Rider is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 09:49 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014